Skip to content
Laskyr

Plugins · chaty · data as of 2026-11-01

Is Floating Chat Widget safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (3.6.3)

As of 2026-11-01. 7 issues are on record for older versions; version 3.6.0 or newer fixes all of them that state a fix.

Latest version
3.6.3
Last updated
2026-10-28
Active installs
300,000+
Known issues on record
7
Unpatched in latest
0
Tested up to WP
7.1.4

WhatsApp chat, Facebook Messenger, Telegram, TikTok, Instagram, Email, Line, WeChat Phone call, SMS, 20+ live chat icons & WhatsApp chat pop up 💬 — by Premio

What to do

  1. Update to the latest version (3.6.3). Anything older than 3.6.0 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get chaty --field=version shows what you run; wp plugin update chaty updates it.

Check your version

Known vulnerabilities

7 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.1 CVE-2026-18964 · published 2026-09-11

Reflected cross-site scripting (XSS) in Floating Chat Widget (3.5.9 and older)

Affected
3.5.9 and older
Fixed in
3.6.0 *
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Floating Chat Widget: Contact Chat Icons, Telegram Chat, Line Messenger, WeChat, Email, SMS, Call Button – Chaty plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the 's' parameter in all versions up to, and including, 3.5.9 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link. WordPress's server-side HTML encoding of the 's' search parameter in the <title> element is bypassed because the browser DOM API decodes HTML entities when jQuery's .text() method reads document.title, returning literal special characters that are then embedded unescaped into the constructed HTML attribute value.

NVD CVE-2026-18964Wordfence advisoryCode change (fix)Plugin source

high 7.5 CVE-2026-27370 · published 2026-03-05

Information disclosure in Floating Chat Widget (3.5.1 and older)

Affected
3.5.1 and older
Fixed in
3.5.2
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Insertion of Sensitive Information Into Sent Data vulnerability in Premio Chaty chaty allows Retrieve Embedded Sensitive Data.This issue affects Chaty: from n/a through <= 3.5.1.

NVD CVE-2026-27370Patchstack advisory

medium 5.4 CVE-2025-1450 · published 2025-02-27

Stored cross-site scripting (XSS) in Floating Chat Widget (3.3.5 and older)

Affected
3.3.5 and older
Fixed in
3.3.6 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The Floating Chat Widget: Contact Chat Icons, Telegram Chat, Line Messenger, WeChat, Email, SMS, Call Button, WhatsApp – Chaty plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘data-hover’ parameter in all versions up to, and including, 3.3.5 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2025-1450Wordfence advisoryCode change (fix)Plugin source

medium 4.8 CVE-2023-47759 · published 2023-11-22

Cross-site scripting (XSS) in Floating Chat Widget (3.1.2 and older)

Affected
3.1.2 and older
Fixed in
3.1.3
Access needed (per CVSS)
Needs an admin-level account; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Premio Chaty chaty allows DOM-Based XSS.This issue affects Chaty: from n/a through <= 3.1.2.

NVD CVE-2023-47759Patchstack advisoryPatchstack advisory

medium 6.1 CVE-2023-25019 · published 2023-08-30

Reflected cross-site scripting (XSS) in Floating Chat Widget (3.0.9 and older)

Affected
3.0.9 and older
Fixed in
3.1
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Unauth. Reflected Cross-Site Scripting (XSS) vulnerability in Premio Chaty plugin <= 3.0.9 versions

NVD CVE-2023-25019Patchstack advisory

medium 4.8 CVE-2023-3245 · published 2023-07-17

Stored cross-site scripting (XSS) in Floating Chat Widget (older than 3.1.2)

Affected
older than 3.1.2
Fixed in
3.1.2
Access needed (per CVSS)
Needs an admin-level account; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The Floating Chat Widget WordPress plugin before 3.1.2 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup)

NVD CVE-2023-3245WPScan advisory

medium 4.8 CVE-2021-36846 · published 2022-04-11

Stored cross-site scripting (XSS) in Floating Chat Widget (2.8.3 and older)

Affected
2.8.3 and older
Fixed in
2.8.4 *
Access needed (per CVSS)
Needs an admin-level account; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Authenticated (admin or higher user role) Stored Cross-Site Scripting (XSS) vulnerability in Premio Chaty (WordPress plugin) <= 2.8.3

NVD CVE-2021-36846Patchstack advisorywordpress.org

Recent activity

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Floating Chat Widget vulnerability status badge
<a href="https://laskyr.com/plugins/chaty"><img src="https://laskyr.com/plugins/chaty/badge.svg" alt="Floating Chat Widget vulnerability status"></a>

← Check another plugin · Free hacked-site scan

Site hacked? Get help now
Run free scan Fix it now ($499) Send a message

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit