Plugins · chat-help · data as of 2026-11-04
Is ChatHelp safe? Known vulnerabilities and latest version
- Latest version
- 3.7.1
- Last updated
- 2026-10-31
- Active installs
- 2,000+
- Known issues on record
- 3
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 7.0+
Add a WhatsApp chat button, WooCommerce WhatsApp order button & click-to-chat floating widget. Capture leads & convert visitors via chat. — by ThemeAtelier
What to do
- Update to the latest version (3.7.1). Anything older than 3.5.2 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get chat-help --field=version shows what you run; wp plugin update chat-help updates it.
Check your version
Known vulnerabilities
3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 6.4 CVE-2026-15759 · published 2026-07-17
Stored cross-site scripting (XSS) in ChatHelp (3.5.1 and older)
- Affected
- 3.5.1 and older
- Fixed in
- 3.5.2 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The ChatHelp – Click to Chat Button, WooCommerce Chat to Order & Floating Chat Form plugin for WordPress is vulnerable to Stored Cross-Site Scripting via 'number' and 'group' Shortcode Attributes in all versions up to, and including, 3.5.1 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
NVD CVE-2026-15759Wordfence advisoryCode change (fix)Plugin source
high 7.5 CVE-2026-15291 · published 2026-07-10
Information disclosure in ChatHelp (3.1.3 and older)
- Affected
- 3.1.3 and older
- Fixed in
- 3.1.4 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Chat Help – Click to Chat Button & Form plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 3.1.3 via the REST API endpoints /wp-json/chat-help/v1/leads and /wp-json/chat-help/v1/leads/{id}. This is due to the plugin not performing any authentication and authorization checks. This makes it possible for unauthenticated attackers to extract sensitive data including customer names, email addresses, phone numbers, WhatsApp messages, complete geolocation data (IP addresses, city, country, ISP, coordinates), device fingerprinting information (browser, OS, screen resolution), and WordPress account credentials (user IDs, usernames, emails, names) for logged-in users who submit forms.
NVD CVE-2026-15291Wordfence advisoryCode change (fix)Plugin source
medium 5.3 CVE-2025-66099 · published 2025-11-21
Missing authorization check in ChatHelp (3.1.3 and older)
- Affected
- 3.1.3 and older
- Fixed in
- 3.1.4
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Missing Authorization vulnerability in ThemeAtelier Chat Help chat-help allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Chat Help: from n/a through <= 3.1.3.
Recent activity
- 2026-10-31 — latest release on wordpress.org (3.7.1).
- 2026-07-17 — Stored cross-site scripting (XSS) disclosed (CVE-2026-15759), fixed in 3.5.2.
- 2026-07-10 — Information disclosure disclosed (CVE-2026-15291), fixed in 3.1.4.
- 2025-11-21 — Missing authorization check disclosed (CVE-2025-66099), fixed in 3.1.4.
Get an email when ChatHelp has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for ChatHelp (chat-help) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by ThemeAtelier (4 tracked)
Types found in this plugin: Cross-site scripting (XSS) (1) · Sensitive data exposure (1) · Missing authorization (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/chat-help (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/chat-help"><img src="https://laskyr.com/plugins/chat-help/badge.svg" alt="ChatHelp vulnerability status"></a>