Plugins · chart-builder · data as of 2026-11-04
Is Chartify safe? Known vulnerabilities and latest version
- Latest version
- 3.8.1
- Last updated
- 2026-09-25
- Active installs
- 3,000+
- Known issues on record
- 7
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 7.0+
Chartify is a powerful WordPress Chart Builder Plugin that will help you to create WordPress Graphs & Charts easily and quickly. — by Ays Pro
What to do
- Update to the latest version (3.8.1). Anything older than 3.6.4 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get chart-builder --field=version shows what you run; wp plugin update chart-builder updates it.
Check your version
Known vulnerabilities
7 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 4.3 CVE-2025-66529 · published 2025-12-09
Cross-site request forgery (CSRF) in Chartify (3.6.3 and older)
- Affected
- 3.6.3 and older
- Fixed in
- 3.6.4
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Cross-Site Request Forgery (CSRF) vulnerability in Ays Pro Chartify chart-builder allows Cross Site Request Forgery.This issue affects Chartify: from n/a through <= 3.6.3.
medium 5.3 CVE-2025-11171 · published 2025-10-08
Authentication bypass in Chartify (3.5.9 and older)
- Affected
- 3.5.9 and older
- Fixed in
- 3.6.0 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Chartify – WordPress Chart Plugin for WordPress is vulnerable to Missing Authentication for Critical Function in all versions up to, and including, 3.5.9. This is due to the plugin registering an unauthenticated AJAX action that dispatches to admin-class methods based on a request parameter, without any nonce or capability checks. This makes it possible for unauthenticated attackers to execute administrative functions via the wp-admin/admin-ajax.php endpoint granted they can identify callable method names.
NVD CVE-2025-11171Wordfence advisoryCode change (fix)Plugin source
medium 4.3 CVE-2025-54673 · published 2025-08-14
Cross-site request forgery (CSRF) in Chartify (3.5.3 and older)
- Affected
- 3.5.3 and older
- Fixed in
- 3.5.4
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Cross-Site Request Forgery (CSRF) vulnerability in Ays Pro Chartify chart-builder allows Cross Site Request Forgery.This issue affects Chartify: from n/a through <= 3.5.3.
medium 5.9 CVE-2025-30904 · published 2025-03-27
Stored cross-site scripting (XSS) in Chartify (3.1.7 and older)
- Affected
- 3.1.7 and older
- Fixed in
- 3.1.9
- Access needed (per CVSS)
- Needs an admin-level account; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Ays Pro Chartify chart-builder allows Stored XSS.This issue affects Chartify: from n/a through <= 3.1.7.
critical 9.8 CVE-2024-10571 · published 2024-11-14
File inclusion in Chartify (2.9.5 and older)
- Affected
- 2.9.5 and older
- Fixed in
- 3.0.0 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Chartify – WordPress Chart Plugin plugin for WordPress is vulnerable to Local File Inclusion in all versions up to, and including, 2.9.5 via the 'source' parameter. This makes it possible for unauthenticated attackers to include and execute arbitrary files on the server, allowing the execution of any PHP code in those files. This can be used to bypass access controls, obtain sensitive data, or achieve code execution in cases where images and other “safe” file types can be uploaded and included.
NVD CVE-2024-10571Wordfence advisoryabrahack.comPlugin source
high 7.1 CVE-2024-47347 · published 2024-10-06
Reflected cross-site scripting (XSS) in Chartify (2.7.6 and older)
- Affected
- 2.7.6 and older
- Fixed in
- 2.7.7
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Ays Pro Chartify chart-builder allows Reflected XSS.This issue affects Chartify: from n/a through <= 2.7.6.
medium 4.8 CVE-2023-47526 · published 2024-02-12
Stored cross-site scripting (XSS) in Chartify (2.0.6 and older)
- Affected
- 2.0.6 and older
- Fixed in
- 2.0.7
- Access needed (per CVSS)
- Needs an admin-level account; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Chart Builder Team Chartify – WordPress Chart Plugin allows Stored XSS.This issue affects Chartify – WordPress Chart Plugin: from n/a through 2.0.6.
Recent activity
- 2026-09-25 — latest release on wordpress.org (3.8.1).
- 2025-12-09 — Cross-site request forgery (CSRF) disclosed (CVE-2025-66529), fixed in 3.6.4.
- 2025-10-08 — Authentication bypass disclosed (CVE-2025-11171), fixed in 3.6.0.
- 2025-08-14 — Cross-site request forgery (CSRF) disclosed (CVE-2025-54673), fixed in 3.5.4.
Get an email when Chartify has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Chartify (chart-builder) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by Ays Pro (13 tracked)
Types found in this plugin: Cross-site scripting (XSS) (3) · Cross-site request forgery (CSRF) (2) · Authentication bypass (1) · File inclusion (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/chart-builder (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/chart-builder"><img src="https://laskyr.com/plugins/chart-builder/badge.svg" alt="Chartify vulnerability status"></a>