Plugins · change-wp-admin-login · data as of 2026-11-04
Is All In One Login safe? Known vulnerabilities and latest version
- Latest version
- 2.5.1
- Last updated
- 2026-10-30
- Active installs
- 60,000+
- Known issues on record
- 2
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 7.4+
Secure and customize your WordPress login page with a custom login URL, 2FA, CAPTCHA, and more. — by Saad Iqbal
What to do
- Update to the latest version (2.5.1). Anything older than 2.5.0 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get change-wp-admin-login --field=version shows what you run; wp plugin update change-wp-admin-login updates it.
Check your version
Known vulnerabilities
2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
high 7.1 CVE-2026-94175 · published 2026-10-30
Cross-site scripting (XSS) in All In One Login (2.4.1 and older)
- Affected
- 2.4.1 and older
- Fixed in
- 2.5.0
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Unauthenticated Cross Site Scripting (XSS) in All In One Login <= 2.4.1 versions.
medium 5.3 CVE-2025-58595 · published 2025-11-06
Authentication bypass in All In One Login (2.0.8 and older)
- Affected
- 2.0.8 and older
- Fixed in
- 2.0.9
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Authentication Bypass by Spoofing vulnerability in Saad Iqbal All In One Login change-wp-admin-login allows Identity Spoofing.This issue affects All In One Login: from n/a through <= 2.0.8.
Recent activity
- 2026-10-30 — latest release on wordpress.org (2.5.1).
- 2026-10-30 — Cross-site scripting (XSS) disclosed (CVE-2026-94175), fixed in 2.5.0.
- 2025-11-06 — Authentication bypass disclosed (CVE-2025-58595), fixed in 2.0.9.
Get an email when All In One Login has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for All In One Login (change-wp-admin-login) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by Saad Iqbal (16 tracked)
Types found in this plugin: Cross-site scripting (XSS) (1) · Authentication bypass (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/change-wp-admin-login (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/change-wp-admin-login"><img src="https://laskyr.com/plugins/change-wp-admin-login/badge.svg" alt="All In One Login vulnerability status"></a>