Plugins · cf7-views · data as of 2026-11-04
Is CF7 Views safe? Known vulnerabilities and latest version
- Latest version
- 3.2.6
- Last updated
- 2026-09-25
- Active installs
- 1,000+
- Known issues on record
- 3
- Unpatched in latest
- 1
- Tested up to WP
- 7.1.4 · PHP 7.0+
Easily display Contact Form 7 Entries/Submissions on your site frontend. — by Aman
What to do
- There is no fixed version yet. If you can live without CF7 Views for now, deactivate it and delete it until the developer ships a fix.
- If you must keep it, limit who can log in (remove unused accounts, especially low-level ones) and put a web application firewall in front of the site.
- Watch for an update: get an email when this page changes.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan, or have us clean it: Emergency Cleanup, $499.
With WP-CLI: wp plugin get cf7-views --field=version shows what you run; wp plugin update cf7-views updates it.
Check your version
Known vulnerabilities
3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
high 7.1 affects latest 3.2.6 CVE-2026-40807 · published 2026-10-06
Cross-site scripting (XSS) in CF7 Views (3.2.6 and older)
- Affected
- 3.2.6 and older
- Fixed in
- no fix listed yet
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Unauthenticated Cross Site Scripting (XSS) in CF7 Views – Complete Entry Management for Contact Form 7 <= 3.2.6 versions.
medium 6.5 CVE-2026-100513 · published 2026-09-30
Cross-site scripting (XSS) in CF7 Views (3.2.5 and older)
- Affected
- 3.2.5 and older
- Fixed in
- 3.2.6
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Contributor Cross Site Scripting (XSS) in CF7 Views – Complete Entry Management for Contact Form 7 <= 3.2.5 versions.
high 7.1 CVE-2026-57411 · published 2026-07-13
Cross-site scripting (XSS) in CF7 Views (3.2.2 and older)
- Affected
- 3.2.2 and older
- Fixed in
- 3.2.3
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Aman CF7 Views – Complete Entry Management for Contact Form 7 cf7-views allows DOM-Based XSS.This issue affects CF7 Views – Complete Entry Management for Contact Form 7: from n/a through <= 3.2.2.
Recent activity
- 2026-09-25 — latest release on wordpress.org (3.2.6).
- 2026-10-06 — Cross-site scripting (XSS) disclosed (CVE-2026-40807), no fix listed yet.
- 2026-09-30 — Cross-site scripting (XSS) disclosed (CVE-2026-100513), fixed in 3.2.6.
- 2026-07-13 — Cross-site scripting (XSS) disclosed (CVE-2026-57411), fixed in 3.2.3.
Get an email when CF7 Views has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for CF7 Views (cf7-views) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by Aman (4 tracked)
Types found in this plugin: Cross-site scripting (XSS) (3)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/cf7-views (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/cf7-views"><img src="https://laskyr.com/plugins/cf7-views/badge.svg" alt="CF7 Views vulnerability status"></a>