Plugins · cf7-styler-for-divi · data as of 2026-11-04
Is CF7 Mate safe? Known vulnerabilities and latest version
- Latest version
- 4.1.1
- Last updated
- 2026-10-29
- Active installs
- 20,000+
- Known issues on record
- 1
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 7.4+
Style Contact Form 7 forms. Add multi-step forms, conditional logic and a submissions database. All free, with an AI form builder. — by Fahim Reza
What to do
- Update to the latest version (4.1.1). Anything older than 4.1.1 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get cf7-styler-for-divi --field=version shows what you run; wp plugin update cf7-styler-for-divi updates it.
Check your version
Known vulnerabilities
1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 5.3 CVE-2026-62057 · published 2026-10-30
Cross-site scripting (XSS) in CF7 Mate (4.1.0 and older)
- Affected
- 4.1.0 and older
- Fixed in
- 4.1.1
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Script-Related HTML Tags in a Web Page (Basic XSS) vulnerability in Fahim Reza Divi Contact Form 7 cf7-styler-for-divi allows Code Injection.This issue affects Divi Contact Form 7: from n/a through 4.1.0.
Recent activity
- 2026-10-29 — latest release on wordpress.org (4.1.1).
- 2026-10-30 — Cross-site scripting (XSS) disclosed (CVE-2026-62057), fixed in 4.1.1.
Get an email when CF7 Mate has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for CF7 Mate (cf7-styler-for-divi) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by Fahim Reza (2 tracked)
Types found in this plugin: Cross-site scripting (XSS) (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/cf7-styler-for-divi (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/cf7-styler-for-divi"><img src="https://laskyr.com/plugins/cf7-styler-for-divi/badge.svg" alt="CF7 Mate vulnerability status"></a>