Plugins · cf7-redirect-thank-you-page · data as of 2026-11-04
Is Business Essentials for Contact Form 7 safe? Known vulnerabilities and latest version
- Latest version
- 1.2.2
- Last updated
- 2026-09-26
- Active installs
- 7,000+
- Known issues on record
- 4
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 5.6+
Business Essentials for Contact Form 7 — by Scott Paterson
What to do
- Update to the latest version (1.2.2). Anything older than 1.2.2 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get cf7-redirect-thank-you-page --field=version shows what you run; wp plugin update cf7-redirect-thank-you-page updates it.
Check your version
Known vulnerabilities
4 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
high 7.2 CVE-2026-97661 · published 2026-10-01
Stored cross-site scripting (XSS) in Business Essentials for Contact Form 7 (1.2.1 and older)
- Affected
- 1.2.1 and older
- Fixed in
- 1.2.2 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Business Essentials for Contact Form 7 plugin for WordPress is vulnerable to Stored Cross-Site Scripting via 'gateway' Form Field in all versions up to, and including, 1.2.1 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. Exploitation requires the Payments module to be enabled and a form to be configured to accept both PayPal and Stripe as payment gateways.
NVD CVE-2026-97661Wordfence advisoryCode change (fix)Plugin source
medium 6.1 CVE-2024-12423 · published 2025-01-15
Reflected cross-site scripting (XSS) in Business Essentials for Contact Form 7 (1.0.7 and older)
- Affected
- 1.0.7 and older
- Fixed in
- 1.0.8 *
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Contact Form 7 Redirect & Thank You Page plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the 'post' parameter in all versions up to, and including, 1.0.7 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link.
NVD CVE-2024-12423Wordfence advisoryCode change (fix)Plugin source
medium 6.1 CVE-2024-10685 · published 2024-11-12
Reflected cross-site scripting (XSS) in Business Essentials for Contact Form 7 (1.0.6 and older)
- Affected
- 1.0.6 and older
- Fixed in
- 1.0.7 *
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Contact Form 7 Redirect & Thank You Page plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the 'tab' parameter in all versions up to, and including, 1.0.6 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link.
high 8.8 CVE-2023-24395 · published 2023-07-10
Cross-site request forgery (CSRF) in Business Essentials for Contact Form 7 (1.0.3 and older)
- Affected
- 1.0.3 and older
- Fixed in
- 1.0.4
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
Cross-Site Request Forgery (CSRF) vulnerability in Scott Paterson Contact Form 7 Redirect & Thank You Page plugin <= 1.0.3 versions.
Recent activity
- 2026-09-26 — latest release on wordpress.org (1.2.2).
- 2026-10-01 — Stored cross-site scripting (XSS) disclosed (CVE-2026-97661), fixed in 1.2.2.
- 2025-01-15 — Reflected cross-site scripting (XSS) disclosed (CVE-2024-12423), fixed in 1.0.8.
- 2024-11-12 — Reflected cross-site scripting (XSS) disclosed (CVE-2024-10685), fixed in 1.0.7.
Get an email when Business Essentials for Contact Form 7 has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Business Essentials for Contact Form 7 (cf7-redirect-thank-you-page) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by Scott Paterson (5 tracked)
Types found in this plugin: Cross-site scripting (XSS) (3) · Cross-site request forgery (CSRF) (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/cf7-redirect-thank-you-page (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/cf7-redirect-thank-you-page"><img src="https://laskyr.com/plugins/cf7-redirect-thank-you-page/badge.svg" alt="Business Essentials for Contact Form 7 vulnerability status"></a>