Skip to content
Laskyr

Plugins · cf7-google-sheets-connector · data as of 2026-11-04

Is GSheetConnector safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (5.6.1)

As of 2026-11-04. 4 issues are on record for older versions; version 5.2.2 or newer fixes all of them that state a fix.

Latest version
5.6.1
Last updated
2026-10-10
Active installs
40,000+
Known issues on record
4
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

Send Contact Form 7 submissions to Google Sheets automatically in real time and keep every form entry organized and easy to access. — by WesternDeal

What to do

  1. Update to the latest version (5.6.1). Anything older than 5.2.2 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get cf7-google-sheets-connector --field=version shows what you run; wp plugin update cf7-google-sheets-connector updates it.

Check your version

Known vulnerabilities

4 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 4.9 CVE-2026-16614 · published 2026-08-01

SQL injection in GSheetConnector (5.2.1 and older)

Affected
5.2.1 and older
Fixed in
5.2.2 *
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The GSheetConnector – CF7 Google Sheets Connector with Real-Time Sync plugin for WordPress is vulnerable to generic SQL Injection via the 's' parameter in all versions up to, and including, 5.2.1 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for authenticated attackers, with administrator-level access and above, to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database. wp_unslash() strips magic-quote protection and sanitize_text_field() does not escape SQL metacharacters, leaving single quotes and other SQL metacharacters intact before the value is interpolated into the query.

NVD CVE-2026-16614Wordfence advisoryCode change (fix)Plugin source

medium 5.3 CVE-2025-22686 · published 2025-02-03

Missing authorization check in GSheetConnector (5.0.17 and older)

Affected
5.0.17 and older
Fixed in
5.0.18
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in WesternDeal CF7 Google Sheets Connector cf7-google-sheets-connector allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects CF7 Google Sheets Connector: from n/a through <= 5.0.17.

NVD CVE-2025-22686Patchstack advisory

medium 6.5 CVE-2024-5654 · published 2024-06-08

Missing authorization check in GSheetConnector (5.0.9 and older)

Affected
5.0.9 and older
Fixed in
5.0.10 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The CF7 Google Sheets Connector plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the 'execute_post_data_cg7_free' function in all versions up to, and including, 5.0.9. This makes it possible for unauthenticated attackers to toggle site configuration settings, including WP_DEBUG, WP_DEBUG_LOG, SCRIPT_DEBUG, and SAVEQUERIES.

NVD CVE-2024-5654Wordfence advisoryCode change (fix)Plugin source

high 7.5 CVE-2023-44989 · published 2024-03-26

Information disclosure in GSheetConnector (5.0.5 and older)

Affected
5.0.5 and older
Fixed in
5.0.6
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Insertion of Sensitive Information into Log File vulnerability in GSheetConnector CF7 Google Sheets Connector.This issue affects CF7 Google Sheets Connector: from n/a through 5.0.5.

NVD CVE-2023-44989Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
GSheetConnector vulnerability status badge
<a href="https://laskyr.com/plugins/cf7-google-sheets-connector"><img src="https://laskyr.com/plugins/cf7-google-sheets-connector/badge.svg" alt="GSheetConnector vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit