Plugins · cf-geoplugin · data as of 2026-11-04
Is Geo Controller safe? Known vulnerabilities and latest version
- Latest version
- 9.0.8
- Last updated
- 2026-10-22
- Active installs
- 1,000+
- Known issues on record
- 8
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 7.0+
WordPress geolocation and geotargeting with IP lookup, geo redirects, dynamic content, WooCommerce localization and visitor blocking. — by INFINITUM FORM
What to do
- Update to the latest version (9.0.8). Anything older than 8.9.9 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get cf-geoplugin --field=version shows what you run; wp plugin update cf-geoplugin updates it.
Check your version
Known vulnerabilities
8 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
critical 9.8 CVE-2026-78286 · published 2026-08-27
PHP object injection in Geo Controller (8.9.8 and older)
- Affected
- 8.9.8 and older
- Fixed in
- 8.9.9
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Unauthenticated PHP Object Injection in Geo Controller <= 8.9.8 versions.
medium 6.5 CVE-2023-51513 · published 2026-01-05
Cross-site scripting (XSS) in Geo Controller (8.5.2 and older)
- Affected
- 8.5.2 and older
- Fixed in
- 8.5.3
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in INTINITUM FORM Geo Controller allows DOM-Based XSS.This issue affects Geo Controller: from n/a through 8.5.2.
medium 5.3 CVE-2025-62109 · published 2025-12-09
Information disclosure in Geo Controller (8.9.4 and older)
- Affected
- 8.9.4 and older
- Fixed in
- 8.9.5 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Insertion of Sensitive Information Into Sent Data vulnerability in INFINITUM FORM Geo Controller cf-geoplugin allows Retrieve Embedded Sensitive Data.This issue affects Geo Controller: from n/a through <= 8.9.4.
medium 5.3 CVE-2024-7381 · published 2024-09-05
Missing authorization check in Geo Controller (8.6.9 and older)
- Affected
- 8.6.9 and older
- Fixed in
- 8.8.0 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
The Geo Controller plugin for WordPress is vulnerable to unauthorized shortcode execution due to missing authorization and capability checks on the ajax__shortcode_cache function in all versions up to, and including, 8.6.9. This makes it possible for unauthenticated attackers to execute arbitrary shortcodes available on the target site.
medium 4.3 CVE-2024-7380 · published 2024-09-05
Missing authorization check in Geo Controller (8.7.3 and older)
- Affected
- 8.7.3 and older
- Fixed in
- 8.8.0 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Geo Controller plugin for WordPress is vulnerable to unauthorized menu creation/deletion due to missing capability checks on the ajax__geolocate_menu and ajax__geolocate_remove_menu functions in all versions up to, and including, 8.7.3. This makes it possible for authenticated attackers, with Subscriber-level access and above, to create or delete WordPress menus.
medium 6.5 CVE-2024-3591 · published 2024-05-01
PHP object injection in Geo Controller (older than 8.6.5)
- Affected
- older than 8.6.5
- Fixed in
- 8.6.5
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory
The Geo Controller WordPress plugin before 8.6.5 unserializes user input via some of its AJAX actions and REST API routes, which could allow unauthenticated users to perform PHP Object Injection when a suitable gadget is present on the blog.
medium 6.5 CVE-2024-30451 · published 2024-03-29
Stored cross-site scripting (XSS) in Geo Controller (8.6.4 and older)
- Affected
- 8.6.4 and older
- Fixed in
- 8.6.5
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in INFINITUM FORM Geo Controller allows Stored XSS.This issue affects Geo Controller: from n/a through 8.6.4.
critical 9.0 CVE-2024-30227 · published 2024-03-28
PHP object injection in Geo Controller (8.6.4 and older)
- Affected
- 8.6.4 and older
- Fixed in
- 8.6.5
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Deserialization of Untrusted Data vulnerability in INFINITUM FORM Geo Controller.This issue affects Geo Controller: from n/a through 8.6.4.
Recent activity
- 2026-10-22 — latest release on wordpress.org (9.0.8).
- 2026-08-27 — PHP object injection disclosed (CVE-2026-78286), fixed in 8.9.9.
- 2026-01-05 — Cross-site scripting (XSS) disclosed (CVE-2023-51513), fixed in 8.5.3.
- 2025-12-09 — Information disclosure disclosed (CVE-2025-62109), fixed in 8.9.5.
Get an email when Geo Controller has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Geo Controller (cf-geoplugin) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: PHP object injection (3) · Cross-site scripting (XSS) (2) · Missing authorization (2) · Sensitive data exposure (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/cf-geoplugin (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/cf-geoplugin"><img src="https://laskyr.com/plugins/cf-geoplugin/badge.svg" alt="Geo Controller vulnerability status"></a>