Skip to content
Laskyr

Plugins · cbxwpbookmark · data as of 2026-11-04

Is CBX Bookmark & Favorite safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.0.10)

As of 2026-11-04. 5 issues are on record for older versions; version 2.0.5 or newer fixes all of them that state a fix.

Latest version
2.0.10
Last updated
2026-08-25
Active installs
1,000+
Known issues on record
5
Unpatched in latest
0
Tested up to WP
7.1.4

Bookmark and Favorite plugin for WordPress with category/list support. — by Sabuj Kundu

What to do

  1. Update to the latest version (2.0.10). Anything older than 2.0.5 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get cbxwpbookmark --field=version shows what you run; wp plugin update cbxwpbookmark updates it.

Check your version

Known vulnerabilities

5 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.5 CVE-2025-13652 · published 2026-01-06

SQL injection in CBX Bookmark & Favorite (2.0.4 and older)

Affected
2.0.4 and older
Fixed in
2.0.5 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The CBX Bookmark & Favorite plugin for WordPress is vulnerable to generic SQL Injection via the ‘orderby’ parameter in all versions up to, and including, 2.0.4 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for authenticated attackers, with Subscriber-level access and above, to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database.

NVD CVE-2025-13652Wordfence advisoryCode change (fix)

medium 4.3 CVE-2025-66101 · published 2025-11-21

Missing authorization check in CBX Bookmark & Favorite (2.0.1 and older)

Affected
2.0.1 and older
Fixed in
2.0.2
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in Sabuj Kundu CBX Bookmark & Favorite cbxwpbookmark allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects CBX Bookmark & Favorite: from n/a through <= 2.0.1.

NVD CVE-2025-66101Patchstack advisory

medium 6.5 CVE-2024-32577 · published 2024-04-18

Stored cross-site scripting (XSS) in CBX Bookmark & Favorite (1.7.20 and older)

Affected
1.7.20 and older
Fixed in
1.7.22
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Codeboxr Team CBX Bookmark & Favorite cbxwpbookmark allows Stored XSS.This issue affects CBX Bookmark & Favorite: from n/a through 1.7.20.

NVD CVE-2024-32577Patchstack advisory

high 7.6 CVE-2024-32132 · published 2024-04-15

SQL injection in CBX Bookmark & Favorite (1.7.20 and older)

Affected
1.7.20 and older
Fixed in
1.7.22 *
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in Codeboxr Team CBX Bookmark & Favorite.This issue affects CBX Bookmark & Favorite: from n/a through 1.7.20.

NVD CVE-2024-32132Patchstack advisory

medium 5.4 CVE-2023-51514 · published 2024-02-01

Stored cross-site scripting (XSS) in CBX Bookmark & Favorite (1.7.13 and older)

Affected
1.7.13 and older
Fixed in
1.7.14
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Codeboxr Team CBX Bookmark & Favorite allows Stored XSS.This issue affects CBX Bookmark & Favorite: from n/a through 1.7.13.

NVD CVE-2023-51514Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
CBX Bookmark & Favorite vulnerability status badge
<a href="https://laskyr.com/plugins/cbxwpbookmark"><img src="https://laskyr.com/plugins/cbxwpbookmark/badge.svg" alt="CBX Bookmark & Favorite vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit