Skip to content
Laskyr

Plugins · catfolders · data as of 2026-11-04

Is CatFolders safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.5.7)

As of 2026-11-04. 2 issues are on record for older versions; version 2.5.4 or newer fixes all of them that state a fix.

Latest version
2.5.7
Last updated
2026-11-01
Active installs
6,000+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.2+

Organize and manage your files with WordPress media folders. Fast, flexible, and professional. — by CatFolders

What to do

  1. Update to the latest version (2.5.7). Anything older than 2.5.4 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get catfolders --field=version shows what you run; wp plugin update catfolders updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 5.3 CVE-2025-66120 · published 2025-12-16

Missing authorization check in CatFolders (2.5.3 and older)

Affected
2.5.3 and older
Fixed in
2.5.4
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in CatFolders CatFolders catfolders allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects CatFolders: from n/a through <= 2.5.3.

NVD CVE-2025-66120Patchstack advisory

medium 6.5 CVE-2025-9776 · published 2025-09-11

SQL injection in CatFolders (2.5.2 and older)

Affected
2.5.2 and older
Fixed in
2.5.3 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The CatFolders – Tame Your WordPress Media Library by Category plugin for WordPress is vulnerable to time-based SQL Injection via the CSV Import contents in all versions up to, and including, 2.5.2 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for authenticated attackers, with Author-level access and above, to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database.

NVD CVE-2025-9776Wordfence advisoryPlugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
CatFolders vulnerability status badge
<a href="https://laskyr.com/plugins/catfolders"><img src="https://laskyr.com/plugins/catfolders/badge.svg" alt="CatFolders vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit