Plugins · category-icon · data as of 2026-11-04
Is Category Icon safe? Known vulnerabilities and latest version
- Latest version
- 1.0.5
- Last updated
- 2026-08-13
- Active installs
- 2,000+
- Known issues on record
- 4
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 7.4+
A WordPress plugin to attach an icon and/or image to taxonomy terms. — by pixelgrade
What to do
- Update to the latest version (1.0.5). Anything older than 1.0.4 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get category-icon --field=version shows what you run; wp plugin update category-icon updates it.
Check your version
Known vulnerabilities
4 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 5.9 CVE-2025-68525 · published 2025-12-24
Stored cross-site scripting (XSS) in Category Icon (1.0.2 and older)
- Affected
- 1.0.2 and older
- Fixed in
- 1.0.3
- Access needed (per CVSS)
- Needs an admin-level account; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in pixelgrade Category Icon category-icon allows Stored XSS.This issue affects Category Icon: from n/a through <= 1.0.2.
critical 9.1 CVE-2025-31039 · published 2025-06-09
Security issue in Category Icon (1.0.3 and older)
- Affected
- 1.0.3 and older
- Fixed in
- 1.0.4 *
- Access needed (per CVSS)
- Needs an admin-level account
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Restriction of XML External Entity Reference vulnerability in pixelgrade Category Icon category-icon allows XML Entity Linking.This issue affects Category Icon: from n/a through <= 1.0.3.
medium 4.9 CVE-2025-31825 · published 2025-04-03
Path traversal / file read in Category Icon (1.0.1 and older)
- Affected
- 1.0.1 and older
- Fixed in
- 1.0.2
- Access needed (per CVSS)
- Needs an admin-level account
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') vulnerability in pixelgrade Category Icon category-icon allows Path Traversal.This issue affects Category Icon: from n/a through <= 1.0.1.
medium 6.4 CVE-2024-8915 · published 2024-10-12
Stored cross-site scripting (XSS) in Category Icon (1.0.0 and older)
- Affected
- 1.0.0 and older
- Fixed in
- 1.0.1 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Category Icon plugin for WordPress is vulnerable to Stored Cross-Site Scripting via SVG File uploads in all versions up to, and including, 1.0.0 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Author-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses the SVG file.
NVD CVE-2024-8915Wordfence advisoryCode change (fix)wordpress.orgPlugin source
Recent activity
- 2026-08-13 — latest release on wordpress.org (1.0.5).
- 2025-12-24 — Stored cross-site scripting (XSS) disclosed (CVE-2025-68525), fixed in 1.0.3.
- 2025-06-09 — Security issue disclosed (CVE-2025-31039), fixed in 1.0.4.
- 2025-04-03 — Path traversal / file read disclosed (CVE-2025-31825), fixed in 1.0.2.
Get an email when Category Icon has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Category Icon (category-icon) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by pixelgrade (2 tracked)
Types found in this plugin: Cross-site scripting (XSS) (2) · Path traversal and file read (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/category-icon (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/category-icon"><img src="https://laskyr.com/plugins/category-icon/badge.svg" alt="Category Icon vulnerability status"></a>