Skip to content
Laskyr

Plugins · categories-images · data as of 2026-11-04

Is Categories Images safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (3.3.4)

As of 2026-11-04. 2 issues are on record for older versions; version 3.3.2 or newer fixes all of them that state a fix.

Latest version
3.3.4
Last updated
2026-10-14
Active installs
50,000+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
6.9.11

The Categories Images is a Wordpress plugin allow you to add image to category, tag or custom taxonomy. — by Zahlan

What to do

  1. Update to the latest version (3.3.4). Anything older than 3.3.2 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get categories-images --field=version shows what you run; wp plugin update categories-images updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 5.4 CVE-2026-2505 · published 2026-04-18

Stored cross-site scripting (XSS) in Categories Images (3.3.1 and older)

Affected
3.3.1 and older
Fixed in
3.3.2 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Categories Images plugin for WordPress is vulnerable to Stored Cross-Site Scripting in versions up to, and including, 3.3.1, via the 'z_taxonomy_image' shortcode. This is due to the shortcode rendering path passing attacker-controlled class input into a fallback image builder that concatenates HTML attributes without proper escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts that execute when users interact with the injected frontend page via the 'class' shortcode attribute.

NVD CVE-2026-2505Wordfence advisoryCode change (fix)

medium 6.5 CVE-2026-40734 · published 2026-04-15

Cross-site scripting (XSS) in Categories Images (3.3.1 and older)

Affected
3.3.1 and older
Fixed in
3.3.2
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Zahlan Categories Images categories-images allows DOM-Based XSS.This issue affects Categories Images: from n/a through <= 3.3.1.

NVD CVE-2026-40734Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Categories Images vulnerability status badge
<a href="https://laskyr.com/plugins/categories-images"><img src="https://laskyr.com/plugins/categories-images/badge.svg" alt="Categories Images vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit