Skip to content
Laskyr

Plugins · catalog-mode-pricing-enquiry-forms-promotions · data as of 2026-11-04

Is wModes safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.3.4)

As of 2026-11-04. 1 issue is on record for older versions; version 1.3 or newer fixes all of them that state a fix.

Latest version
1.3.4
Last updated
2026-06-08
Active installs
800+
Known issues on record
1
Unpatched in latest
0
Tested up to WP
7.0.8 · PHP 5.6+

Advanced Catalog Mode, Product Pricing, Enquiry Forms & Promotions for WooCommerce — by sundayfanz

What to do

  1. Update to the latest version (1.3.4). Anything older than 1.3 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get catalog-mode-pricing-enquiry-forms-promotions --field=version shows what you run; wp plugin update catalog-mode-pricing-enquiry-forms-promotions updates it.

Check your version

Known vulnerabilities

1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 4.3 CVE-2025-12639 · published 2025-11-18

Information disclosure in wModes (1.2.2 and older)

Affected
1.2.2 and older
Fixed in
1.3 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The wModes – Catalog Mode, Product Pricing, Enquiry Forms & Promotions plugin for WordPress is vulnerable to authorization bypass in versions up to, and including, 1.2.2. This is due to the plugin not properly verifying that a user is authorized to access sensitive information via the AJAX endpoint. This makes it possible for authenticated attackers, with subscriber-level access and above, to extract sensitive information including user emails, usernames, roles, capabilities, and WooCommerce data such as products and payment methods.

NVD CVE-2025-12639Wordfence advisoryCode change (fix)Plugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
wModes vulnerability status badge
<a href="https://laskyr.com/plugins/catalog-mode-pricing-enquiry-forms-promotions"><img src="https://laskyr.com/plugins/catalog-mode-pricing-enquiry-forms-promotions/badge.svg" alt="wModes vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit