Skip to content
Laskyr

Plugins · cartasi-x-pay · data as of 2026-11-04

Is Nexi XPay safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (8.4.0)

As of 2026-11-04. 2 issues are on record for older versions; version 8.3.2 or newer fixes all of them that state a fix.

Latest version
8.4.0
Last updated
2026-07-31
Active installs
7,000+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
7.0.8

XPay is the payment gateway provided by Nexi, a leading group in Italy with the goal of shaping the future of digital payments. — by Nexi Payments

What to do

  1. Update to the latest version (8.4.0). Anything older than 8.3.2 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get cartasi-x-pay --field=version shows what you run; wp plugin update cartasi-x-pay updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 7.5 CVE-2026-54810 · published 2026-06-17

Missing authorization check in Nexi XPay (8.3.1 and older)

Affected
8.3.1 and older
Fixed in
8.3.2
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in Nexi Payments Nexi XPay allows Exploiting Incorrectly Configured Access Control Security Levels. This issue affects Nexi XPay: from n/a through 8.3.1.

NVD CVE-2026-54810Patchstack advisory

medium 5.3 CVE-2025-15565 · published 2026-04-14

Missing authorization check in Nexi XPay (8.3.0 and older)

Affected
8.3.0 and older
Fixed in
8.3.1 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Nexi XPay plugin for WordPress is vulnerable to unauthorized modification of data due to missing authorization checks on the redirect function in all versions up to, and including, 8.3.0. This makes it possible for unauthenticated attackers to mark pending WooCommerce orders as paid/completed.

NVD CVE-2025-15565Wordfence advisoryPlugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Nexi XPay vulnerability status badge
<a href="https://laskyr.com/plugins/cartasi-x-pay"><img src="https://laskyr.com/plugins/cartasi-x-pay/badge.svg" alt="Nexi XPay vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit