Skip to content
Laskyr

Plugins · cart-rest-api-for-woocommerce · data as of 2026-11-04

Is CoCart safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (4.9.7)

As of 2026-11-04. 2 issues are on record for older versions; version 4.9.0 or newer fixes all of them that state a fix.

Latest version
4.9.7
Last updated
2026-09-30
Active installs
900+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

Ship your headless WooCommerce storefront faster. CoCart is the REST API built for Next.js, React, Vue, and any modern frontend — developer-first. — by CoCart Headless

What to do

  1. Update to the latest version (4.9.7). Anything older than 4.9.0 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get cart-rest-api-for-woocommerce --field=version shows what you run; wp plugin update cart-rest-api-for-woocommerce updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 7.5 CVE-2026-59536 · published 2026-07-27

Missing authorization check in CoCart (4.8.4 and older)

Affected
4.8.4 and older
Fixed in
4.9.0
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Unauthenticated Broken Access Control in CoCart – Headless ecommerce <= 4.8.4 versions.

NVD CVE-2026-59536Patchstack advisory

medium 5.3 CVE-2023-47241 · published 2025-01-02

Missing authorization check in CoCart (3.11.2 and older)

Affected
3.11.2 and older
Fixed in
3.12.0
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in CoCart Headless CoCart – Headless ecommerce cart-rest-api-for-woocommerce allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects CoCart – Headless ecommerce: from n/a through <= 3.11.2.

NVD CVE-2023-47241Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
CoCart vulnerability status badge
<a href="https://laskyr.com/plugins/cart-rest-api-for-woocommerce"><img src="https://laskyr.com/plugins/cart-rest-api-for-woocommerce/badge.svg" alt="CoCart vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit