Skip to content
Laskyr

Plugins · cart-lift · data as of 2026-11-04

Is Cart Lift safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (3.1.58)

As of 2026-11-04. 2 issues are on record for older versions; version 3.1.58 or newer fixes all of them that state a fix.

Latest version
3.1.58
Last updated
2026-09-24
Active installs
900+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
6.9.11 · PHP 7.4+

Track abandoned carts and send automated, customizable abandoned cart recovery emails. Get more leads, reduce cart abandonment, and increase revenue. — by RexTheme

What to do

  1. Update to the latest version (3.1.58). Anything older than 3.1.58 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get cart-lift --field=version shows what you run; wp plugin update cart-lift updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 7.1 CVE-2026-57417 · published 2026-07-13

Stored cross-site scripting (XSS) in Cart Lift (3.1.57 and older)

Affected
3.1.57 and older
Fixed in
3.1.58
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in RexTheme Cart Lift cart-lift allows Stored XSS.This issue affects Cart Lift: from n/a through <= 3.1.57.

NVD CVE-2026-57417Patchstack advisory

medium 6.1 CVE-2022-47449 · published 2023-05-04

Reflected cross-site scripting (XSS) in Cart Lift (3.1.5 and older)

Affected
3.1.5 and older
Fixed in
3.1.6
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Unauth. Reflected Cross-Site Scripting (XSS) vulnerability in RexTheme Cart Lift – Abandoned Cart Recovery for WooCommerce and EDD plugin <= 3.1.5 versions.

NVD CVE-2022-47449Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Cart Lift vulnerability status badge
<a href="https://laskyr.com/plugins/cart-lift"><img src="https://laskyr.com/plugins/cart-lift/badge.svg" alt="Cart Lift vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit