Skip to content
Laskyr

Plugins · career-section · data as of 2026-11-04

Is Career Section safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.8)

As of 2026-11-04. 2 issues are on record for older versions; version 1.8 or newer fixes all of them that state a fix.

Latest version
1.8
Last updated
2026-04-16
Active installs
fewer than 10
Known issues on record
2
Unpatched in latest
0
Tested up to WP
6.9.11 · PHP 7.4+

Just another Career Section plugins. Simple but flexible. — by Md. Shahinur Islam

What to do

  1. Update to the latest version (1.8). Anything older than 1.8 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get career-section --field=version shows what you run; wp plugin update career-section updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

critical 9.8 CVE-2026-6271 · published 2026-05-14

Arbitrary file upload in Career Section (1.7 and older)

Affected
1.7 and older
Fixed in
1.8 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Career Section plugin for WordPress is vulnerable to Arbitrary File Upload in all versions up to, and including, 1.7 via the CV upload handler. This is due to missing file type validation. This makes it possible for unauthenticated attackers to upload files that may be executable, which makes remote code execution possible.

NVD CVE-2026-6271Wordfence advisoryCode change (fix)

high 8.8 CVE-2025-14868 · published 2026-04-16

Cross-site request forgery (CSRF) in Career Section (1.6 and older)

Affected
1.6 and older
Fixed in
1.7 *
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Career Section plugin for WordPress is vulnerable to Cross-Site Request Forgery leading to Path Traversal and Arbitrary File Deletion in all versions up to, and including, 1.6. This is due to missing nonce validation and insufficient file path validation on the delete action in the 'appform_options_page_html' function. This makes it possible for unauthenticated attackers to delete arbitrary files on the server via a forged request, granted they can trick a site administrator into performing an action such as clicking on a link.

NVD CVE-2025-14868Wordfence advisoryCode change (fix)

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Career Section vulnerability status badge
<a href="https://laskyr.com/plugins/career-section"><img src="https://laskyr.com/plugins/career-section/badge.svg" alt="Career Section vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit