Skip to content
Laskyr

Plugins · captcha-code-authentication · data as of 2026-11-04

Is Captcha Code safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (3.33)

As of 2026-11-04. 3 issues are on record for older versions; version 3.33 or newer fixes all of them that state a fix.

Latest version
3.33
Last updated
2026-09-21
Active installs
100,000+
Known issues on record
3
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 5.2+

GDPR compatible captcha anti-spam protection for login form, comments form, registration form & lost password form. Eliminate spam with captcha. — by WebFactory

What to do

  1. Update to the latest version (3.33). Anything older than 3.33 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get captcha-code-authentication --field=version shows what you run; wp plugin update captcha-code-authentication updates it.

Check your version

Known vulnerabilities

3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 4.8 CVE-2026-94457 · published 2026-09-23

Security issue in Captcha Code (3.32 and older)

Affected
3.32 and older
Fixed in
3.33
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Unauthenticated Bypass Vulnerability in Captcha Code <= 3.32 versions.

NVD CVE-2026-94457Patchstack advisory

medium 5.3 CVE-2023-48745 · published 2024-06-04

Security issue in Captcha Code (2.9 and older)

Affected
2.9 and older
Fixed in
3.0
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Restriction of Excessive Authentication Attempts vulnerability in WebFactory Ltd Captcha Code allows Functionality Bypass.This issue affects Captcha Code: from n/a through 2.9.

NVD CVE-2023-48745Patchstack advisory

high 8.8 CVE-2022-37411 · published 2022-09-09

Cross-site request forgery (CSRF) in Captcha Code (2.7 and older)

Affected
2.7 and older
Fixed in
2.8 *
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Cross-Site Request Forgery (CSRF) vulnerability in Vinoj Cardoza's Captcha Code plugin <= 2.7 at WordPress.

NVD CVE-2022-37411Patchstack advisorywordpress.org

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Captcha Code vulnerability status badge
<a href="https://laskyr.com/plugins/captcha-code-authentication"><img src="https://laskyr.com/plugins/captcha-code-authentication/badge.svg" alt="Captcha Code vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit