Skip to content
Laskyr

Plugins · capability-manager-enhanced · data as of 2026-11-04

Is PublishPress Capabilities safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.53.0)

As of 2026-11-04. 7 issues are on record for older versions; version 2.51.0 or newer fixes all of them that state a fix.

Latest version
2.53.0
Last updated
2026-10-14
Active installs
90,000+
Known issues on record
7
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.2.5+

User role editing for WordPress. Manage user roles, control capabilities and permissions, and restrict admin access for any role. — by PublishPress

What to do

  1. Update to the latest version (2.53.0). Anything older than 2.51.0 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get capability-manager-enhanced --field=version shows what you run; wp plugin update capability-manager-enhanced updates it.

Check your version

Known vulnerabilities

7 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 7.2 CVE-2026-48197 · published 2026-10-06

Privilege escalation in PublishPress Capabilities (2.45.0 and older)

Affected
2.45.0 and older
Fixed in
2.50.0
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Incorrect Privilege Assignment vulnerability in PublishPress PublishPress Capabilities capability-manager-enhanced allows Privilege Escalation.This issue affects PublishPress Capabilities: from n/a through 2.45.0.

NVD CVE-2026-48197Patchstack advisory

high 8.1 CVE-2026-94487 · published 2026-09-23

Cross-site request forgery (CSRF) in PublishPress Capabilities (2.50.1 and older)

Affected
2.50.1 and older
Fixed in
2.51.0
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Unauthenticated Cross Site Request Forgery (CSRF) in PublishPress Capabilities <= 2.50.1 versions.

NVD CVE-2026-94487Patchstack advisory

high 7.2 CVE-2026-75927 · published 2026-09-09

Privilege escalation in PublishPress Capabilities (2.50.0 and older)

Affected
2.50.0 and older
Fixed in
2.50.1 *
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The PublishPress Capabilities – User Role Editor, Access Permissions, User Capabilities, Admin Menus plugin for WordPress is vulnerable to Privilege Escalation in all versions up to, and including, 2.50.0. This is due to the `addPluginCapabilities()` function unconditionally granting the Editor role all 15 `manage_capabilities_*` capabilities — including `manage_capabilities`, `manage_capabilities_roles`, `manage_capabilities_settings`, and `manage_capabilities_backup` — via a hard-coded `$eligible_roles = ['administrator', 'editor']` assignment that runs automatically on the first `admin_init` after plugin activation with no administrator opt-in, persisting the grants directly to the database. This makes it possible for authenticated attackers with Editor-level access to elevate their privileges to a site-wide capability manager, enabling them to create, rename, and delete non-system roles, modify capabilities of non-administrator roles, restore role backups, and write arbitrary plugin options whose names begin with `cme_`, `capsman`, `pp_capabilities`, or `presspermit` via `update_option()`. The escalation stops short of full Administrator access, as WordPress's `map_meta_cap` layer still prevents the escalated Editor from granting administrator-only capabilities to other roles; however, all role-management and plugin-settings functionality gated solely on `manage_capabilities_*` capabilities remains fully accessible.

NVD CVE-2026-75927Wordfence advisoryCode change (fix)Plugin source

high 7.2 CVE-2026-28183 · published 2026-08-06

Privilege escalation in PublishPress Capabilities (2.45.0 and older)

Affected
2.45.0 and older
Fixed in
2.50.0
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Incorrect Privilege Assignment vulnerability in PublishPress PublishPress Capabilities capability-manager-enhanced allows Privilege Escalation.This issue affects PublishPress Capabilities: from n/a through 2.45.0.

NVD CVE-2026-28183Patchstack advisory

medium 4.3 CVE-2026-32394 · published 2026-03-13

Missing authorization check in PublishPress Capabilities (2.31.0 and older)

Affected
2.31.0 and older
Fixed in
2.32.0
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in PublishPress PublishPress Capabilities capability-manager-enhanced allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects PublishPress Capabilities: from n/a through <= 2.31.0.

NVD CVE-2026-32394Patchstack advisory

high 7.2 CVE-2022-3366 · published 2022-10-31

PHP object injection in PublishPress Capabilities (older than 2.5.2)

Affected
older than 2.5.2
Fixed in
2.5.2
Access needed (per CVSS)
Needs an admin-level account
Range from
advisory text · score by NVD
Details from the advisory

The PublishPress Capabilities WordPress plugin before 2.5.2, PublishPress Capabilities Pro WordPress plugin before 2.5.2 unserializes the content of imported files, which could lead to PHP object injection attacks by administrators, on multisite WordPress configurations. Successful exploitation in this case requires other plugins with a suitable gadget chain to be present on the site.

NVD CVE-2022-3366WPScan advisory

critical 9.8 CVE-2021-25032 · published 2022-01-10

Cross-site request forgery (CSRF) in PublishPress Capabilities (older than 2.3.1)

Affected
older than 2.3.1
Fixed in
2.3.1
Access needed (per CVSS)
No login needed
Range from
advisory text · score by NVD
Details from the advisory

The PublishPress Capabilities WordPress plugin before 2.3.1, PublishPress Capabilities Pro WordPress plugin before 2.3.1 does not have authorisation and CSRF checks when updating the plugin's settings via the init hook, and does not ensure that the options to be updated belong to the plugin. As a result, unauthenticated attackers could update arbitrary blog options, such as the default role and make any new registered user with an administrator role.

NVD CVE-2021-25032WPScan advisoryCode change (fix)

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
PublishPress Capabilities vulnerability status badge
<a href="https://laskyr.com/plugins/capability-manager-enhanced"><img src="https://laskyr.com/plugins/capability-manager-enhanced/badge.svg" alt="PublishPress Capabilities vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit