Skip to content
Laskyr

Plugins · calendar · data as of 2026-11-04

Is Calendar safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.3.18)

As of 2026-11-04. 4 issues are on record for older versions; version 1.3.18 or newer fixes all of them that state a fix.

Latest version
1.3.18
Last updated
2026-05-16
Active installs
4,000+
Known issues on record
4
Unpatched in latest
0
Tested up to WP
6.9.11

A simple but effective Calendar plugin for WordPress that allows you to manage your events and appointments and display them to the world. — by Kieran O'Shea

What to do

  1. Update to the latest version (1.3.18). Anything older than 1.3.18 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get calendar --field=version shows what you run; wp plugin update calendar updates it.

Check your version

Known vulnerabilities

4 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.8 CVE-2026-14827 · published 2026-07-27

Cross-site scripting (XSS) in Calendar (older than 1.3.18)

Affected
older than 1.3.18
Fixed in
1.3.18
Access needed (per CVSS)
Needs an admin-level account; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory

The Calendar WordPress plugin before 1.3.18 does not properly escape a user-supplied event field before outputting it inside an HTML attribute on a public-facing page, allowing users with the Contributor role to inject arbitrary JavaScript that executes in the browser of anyone viewing the calendar.

NVD CVE-2026-14827WPScan advisory

medium 6.4 CVE-2025-14548 · published 2025-12-23

Stored cross-site scripting (XSS) in Calendar (1.3.16 and older)

Affected
1.3.16 and older
Fixed in
1.3.17 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Calendar plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'event_desc' parameter in all versions up to, and including, 1.3.16 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page, granted they can convince an administrator to enable lower privilege users to manage calendar events via the plugin settings.

NVD CVE-2025-14548Wordfence advisoryCode change (fix)Plugin source

high 8.8 CVE-2024-2831 · published 2024-05-02

SQL injection in Calendar (1.3.14 and older)

Affected
1.3.14 and older
Fixed in
1.3.15 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Calendar plugin for WordPress is vulnerable to SQL Injection via the plugin's shortcodes in all versions up to, and including, 1.3.14 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for authenticated attackers, with contributor access or higher, to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database.

NVD CVE-2024-2831Wordfence advisoryCode change (fix)wordpress.org

medium 6.8 CVE-2013-2698 · published 2014-05-27

Cross-site request forgery (CSRF) in Calendar (1.3.2 and older)

Affected
1.3.2 and older
Fixed in
1.3.3 *
Range from
NVD analysis · score by NVD
Details from the advisory

Cross-site request forgery (CSRF) vulnerability in the Calendar plugin before 1.3.3 for WordPress allows remote attackers to hijack the authentication of users for requests that add a calendar entry via unspecified vectors.

NVD CVE-2013-2698wordpress.orgsecunia.comsecurityfocus.comexchange.xforce.ibmcloud.com

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Calendar vulnerability status badge
<a href="https://laskyr.com/plugins/calendar"><img src="https://laskyr.com/plugins/calendar/badge.svg" alt="Calendar vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit