Skip to content
Laskyr

Plugins · cal-embedder-lite · data as of 2026-11-04

Is UseStrict’s Calendly Embedder safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.2.4)

As of 2026-11-04. 1 issue is on record for older versions; version 1.2 or newer fixes all of them that state a fix.

Latest version
1.2.4
Last updated
2026-11-03
Active installs
2,000+
Known issues on record
1
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

Simple but powerful embedding for Calendly. — by Vinny

What to do

  1. Update to the latest version (1.2.4). Anything older than 1.2 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get cal-embedder-lite --field=version shows what you run; wp plugin update cal-embedder-lite updates it.

Check your version

Known vulnerabilities

1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 5.9 CVE-2025-67555 · published 2025-12-09

Stored cross-site scripting (XSS) in UseStrict’s Calendly Embedder (1.1.7.2 and older)

Affected
1.1.7.2 and older
Fixed in
1.2
Access needed (per CVSS)
Needs an admin-level account; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in useStrict UseStrict's Calendly Embedder cal-embedder-lite allows Stored XSS.This issue affects UseStrict's Calendly Embedder: from n/a through <= 1.1.7.2.

NVD CVE-2025-67555Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
UseStrict’s Calendly Embedder vulnerability status badge
<a href="https://laskyr.com/plugins/cal-embedder-lite"><img src="https://laskyr.com/plugins/cal-embedder-lite/badge.svg" alt="UseStrict’s Calendly Embedder vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit