Plugins · bwl-advanced-faq-manager-lite · data as of 2026-11-04
Is BWL Advanced FAQ Manager Lite safe? Known vulnerabilities and latest version
- Latest version
- 1.1.2
- Last updated
- 2026-03-20
- Active installs
- 20+
- Known issues on record
- 1
- Unpatched in latest
- 0
- Tested up to WP
- 6.9.11 · PHP 8.0+
BWL Advanced FAQ Manager Lite manages FAQs effectively, and you can create and administer unlimited FAQs to give users an extensive knowledge base. — by Mahbub Alam Khan
What to do
- Update to the latest version (1.1.2). Anything older than 1.1.2 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get bwl-advanced-faq-manager-lite --field=version shows what you run; wp plugin update bwl-advanced-faq-manager-lite updates it.
Check your version
Known vulnerabilities
1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 6.4 CVE-2026-4075 · published 2026-03-26
Stored cross-site scripting (XSS) in BWL Advanced FAQ Manager Lite (1.1.1 and older)
- Affected
- 1.1.1 and older
- Fixed in
- 1.1.2 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The BWL Advanced FAQ Manager Lite plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'baf_sbox' shortcode in all versions up to and including 1.1.1. This is due to insufficient input sanitization and output escaping on user-supplied shortcode attributes such as 'sbox_id', 'sbox_class', 'placeholder', 'highlight_color', 'highlight_bg', and 'cont_ext_class'. These attributes are directly interpolated into HTML element attributes without any esc_attr() escaping in the baf_sbox() function. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
NVD CVE-2026-4075Wordfence advisoryCode change (fix)Plugin source
Recent activity
- 2026-03-20 — latest release on wordpress.org (1.1.2).
- 2026-03-26 — Stored cross-site scripting (XSS) disclosed (CVE-2026-4075), fixed in 1.1.2.
Get an email when BWL Advanced FAQ Manager Lite has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for BWL Advanced FAQ Manager Lite (bwl-advanced-faq-manager-lite) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Cross-site scripting (XSS) (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/bwl-advanced-faq-manager-lite (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/bwl-advanced-faq-manager-lite"><img src="https://laskyr.com/plugins/bwl-advanced-faq-manager-lite/badge.svg" alt="BWL Advanced FAQ Manager Lite vulnerability status"></a>