Skip to content
Laskyr

Plugins · button-block · data as of 2026-11-04

Is Button Block safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.2.8)

As of 2026-11-04. 6 issues are on record for older versions; version 1.2.8 or newer fixes all of them that state a fix.

Latest version
1.2.8
Last updated
2026-10-26
Active installs
5,000+
Known issues on record
6
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

Get multi-functional buttons — by bPlugins

What to do

  1. Update to the latest version (1.2.8). Anything older than 1.2.8 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get button-block --field=version shows what you run; wp plugin update button-block updates it.

Check your version

Known vulnerabilities

6 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.5 CVE-2026-116400 · published 2026-10-26

Stored cross-site scripting (XSS) in Button Block (1.2.7 and older)

Affected
1.2.7 and older
Fixed in
1.2.8
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in bPlugins Button Block button-block allows Stored XSS.This issue affects Button Block: from n/a through 1.2.7.

NVD CVE-2026-116400Patchstack advisory

medium 4.3 CVE-2025-54694 · published 2025-08-14

Cross-site request forgery (CSRF) in Button Block (1.2.0 and older)

Affected
1.2.0 and older
Fixed in
1.2.1
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Cross-Site Request Forgery (CSRF) vulnerability in bPlugins Button Block button-block allows Cross Site Request Forgery.This issue affects Button Block: from n/a through <= 1.2.0.

NVD CVE-2025-54694Patchstack advisory

high 8.8 CVE-2025-22787 · published 2025-01-15

Missing authorization check in Button Block (1.1.5 and older)

Affected
1.1.5 and older
Fixed in
1.1.6
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Missing Authorization vulnerability in bPlugins Button Block button-block allows Accessing Functionality Not Properly Constrained by ACLs.This issue affects Button Block: from n/a through <= 1.1.5.

NVD CVE-2025-22787Patchstack advisory

medium 5.4 CVE-2025-22815 · published 2025-01-09

Stored cross-site scripting (XSS) in Button Block (1.1.9 and older)

Affected
1.1.9 and older
Fixed in
1.2.0
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in bPlugins Button Block button-block allows Stored XSS.This issue affects Button Block: from n/a through <= 1.1.9.

NVD CVE-2025-22815Patchstack advisory

medium 6.5 CVE-2024-12560 · published 2024-12-19

Information disclosure in Button Block (1.1.5 and older)

Affected
1.1.5 and older
Fixed in
1.1.6 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The Button Block – Get fully customizable & multi-functional buttons plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 1.1.5 via the 'btn_block_duplicate_post' function. This makes it possible for authenticated attackers, with Contributor-level access and above, to extract potentially sensitive data from draft, scheduled (future), private, and password protected posts.

NVD CVE-2024-12560Wordfence advisoryCode change (fix)

medium 6.5 CVE-2024-10671 · published 2024-11-21

Information disclosure in Button Block (1.1.4 and older)

Affected
1.1.4 and older
Fixed in
1.1.5 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The Button Block – Get fully customizable & multi-functional buttons plugin for WordPress is vulnerable to Information Exposure in all versions up to, and including, 1.1.4 via the [btn_block] shortcode due to insufficient restrictions on which posts can be included. This makes it possible for authenticated attackers, with Contributor-level access and above, to extract data from password protected, private, or draft posts that they should not have access to.

NVD CVE-2024-10671Wordfence advisoryCode change (fix)

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Button Block vulnerability status badge
<a href="https://laskyr.com/plugins/button-block"><img src="https://laskyr.com/plugins/button-block/badge.svg" alt="Button Block vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit