Skip to content
Laskyr

Plugins · bunnycdn · data as of 2026-11-04

Is bunny.net safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (3.1.1)

As of 2026-11-04. 3 issues are on record for older versions; version 2.3.7 or newer fixes all of them that state a fix.

Latest version
3.1.1
Last updated
2026-08-19
Active installs
10,000+
Known issues on record
3
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 8.1+

Enable Bunny CDN to speed up your WordPress website and enjoy greatly improved loading times around the world. — by bunny.net

What to do

  1. Update to the latest version (3.1.1). Anything older than 2.3.7 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get bunnycdn --field=version shows what you run; wp plugin update bunnycdn updates it.

Check your version

Known vulnerabilities

3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.3 CVE-2025-68049 · published 2026-06-15

Missing authorization check in bunny.net (2.3.6 and older)

Affected
2.3.6 and older
Fixed in
2.3.7
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Subscriber Broken Access Control in bunny.net <= 2.3.6 versions.

NVD CVE-2025-68049Patchstack advisory

high 8.5 CVE-2025-48236 · published 2025-05-19

Stored cross-site scripting (XSS) in bunny.net (2.3.0 and older)

Affected
2.3.0 and older
Fixed in
2.3.1
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in bunny.net bunny.net bunnycdn allows Stored XSS.This issue affects bunny.net: from n/a through <= 2.3.0.

NVD CVE-2025-48236Patchstack advisory

medium 5.9 CVE-2024-31361 · published 2024-04-11

Stored cross-site scripting (XSS) in bunny.net (2.0.1 and older)

Affected
2.0.1 and older
Fixed in
2.0.2
Access needed (per CVSS)
Needs an admin-level account; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in bunny.Net allows Stored XSS.This issue affects bunny.Net: from n/a through 2.0.1.

NVD CVE-2024-31361Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
bunny.net vulnerability status badge
<a href="https://laskyr.com/plugins/bunnycdn"><img src="https://laskyr.com/plugins/bunnycdn/badge.svg" alt="bunny.net vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit