Plugins · bulletproof-security · data as of 2026-11-04
Is BulletProof Security safe? Known vulnerabilities and latest version
- Status
- Closed 2026-10-30
- Known issues on record
- 7
- Unpatched in latest
- 0
What to do
- Replace it. A closed plugin gets no updates through WordPress, so any hole found from now on stays open.
- Deactivate and delete it once you have a replacement (Plugins → Deactivate → Delete). Deleting removes its files; deactivating alone leaves them on the server.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan, or have us clean it: Emergency Cleanup, $499.
With WP-CLI, once you have a replacement: wp plugin deactivate bulletproof-security && wp plugin delete bulletproof-security
Check your version
Known vulnerabilities
7 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version. 7 record(s) do not state which versions are affected.
high 7.5 CVE-2025-67931 · published 2026-01-08
Information disclosure in BulletProof Security (6.9 and older)
- Affected
- 6.9 and older
- Fixed in
- 7.0
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Insertion of Sensitive Information Into Sent Data vulnerability in AITpro BulletProof Security bulletproof-security allows Retrieve Embedded Sensitive Data.This issue affects BulletProof Security: from n/a through <= 6.9.
medium 4.8 CVE-2022-1265 · published 2022-05-16
Cross-site scripting (XSS) in BulletProof Security (older than 6.1)
- Affected
- older than 6.1
- Fixed in
- 6.1
- Access needed (per CVSS)
- Needs an admin-level account; someone on the site has to click a link or open a page
- Range from
- NVD analysis · score by NVD
Details from the advisory
The BulletProof Security WordPress plugin before 6.1 does not sanitize and escape some of its CAPTCHA settings, which could allow high-privileged users to perform Cross-Site Scripting attacks even when unfiltered_html is disallowed
medium 4.8 CVE-2022-0590 · published 2022-03-21
Cross-site scripting (XSS) in BulletProof Security (older than 5.8)
- Affected
- older than 5.8
- Fixed in
- 5.8
- Access needed (per CVSS)
- Needs an admin-level account; someone on the site has to click a link or open a page
- Range from
- NVD analysis · score by NVD
Details from the advisory
The BulletProof Security WordPress plugin before 5.8 does not sanitise and escape some of its settings, which could allow high privilege users to perform Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed.
medium 5.3 CVE-2021-39327 · published 2021-09-17
Information disclosure in BulletProof Security (5.1 to 5.1)
- Affected
- 5.1 to 5.1
- Fixed in
- unknown
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
The BulletProof Security WordPress plugin is vulnerable to sensitive information disclosure due to a file path disclosure in the publicly accessible ~/db_backup_log.txt file which grants attackers the full path of the site, in addition to the path of database backup files. This affects versions up to, and including, 5.1.
NVD CVE-2021-39327Code change (fix)packetstormsecurity.comgithub.comexploit-db.comWordfence advisory
medium 5.0 CVE-2014-8749 · published 2014-12-01
Server-side request forgery (SSRF) in BulletProof Security (.51 and older)
- Affected
- .51 and older
- Fixed in
- unknown
- Range from
- NVD analysis · score by NVD
Details from the advisory
Server-side request forgery (SSRF) vulnerability in admin/htaccess/bpsunlock.php in the BulletProof Security plugin before .51.1 for WordPress allows remote attackers to trigger outbound requests that authenticate to arbitrary databases via the dbhost parameter.
medium 4.3 CVE-2014-7958 · published 2014-11-06
Cross-site scripting (XSS) in BulletProof Security (not stated by the source)
- Affected
- not stated by the source
- Fixed in
- unknown
- Range from
- not stated · score by NVD
Details from the advisory
Cross-site scripting (XSS) vulnerability in admin/htaccess/bpsunlock.php in the BulletProof Security plugin before .51.1 for WordPress allows remote attackers to inject arbitrary web script or HTML via the dbhost parameter.
NVD CVE-2014-7958wordpress.orgpacketstormsecurity.comsecurityfocus.comsecurityfocus.com
medium 6.5 CVE-2014-7959 · published 2014-11-06
SQL injection in BulletProof Security (not stated by the source)
- Affected
- not stated by the source
- Fixed in
- unknown
- Range from
- not stated · score by NVD
Details from the advisory
SQL injection vulnerability in admin/htaccess/bpsunlock.php in the BulletProof Security plugin before .51.1 for WordPress allows remote authenticated users to execute arbitrary SQL commands via the tableprefix parameter.
NVD CVE-2014-7959wordpress.orgpacketstormsecurity.comsecurityfocus.comsecurityfocus.com
Recent activity
- 2026-10-30 — closed on wordpress.org.
- 2026-01-08 — Information disclosure disclosed (CVE-2025-67931), fixed in 7.0.
- 2022-05-16 — Cross-site scripting (XSS) disclosed (CVE-2022-1265), fixed in 6.1.
- 2022-03-21 — Cross-site scripting (XSS) disclosed (CVE-2022-0590), fixed in 5.8.
Get an email when BulletProof Security has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for BulletProof Security (bulletproof-security) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Cross-site scripting (XSS) (3) · Sensitive data exposure (2) · Server-side request forgery (SSRF) (1) · SQL injection (1)
Where this data comes from
- Version, last update, installs, closure: wordpress.org/plugins/bulletproof-security (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/bulletproof-security"><img src="https://laskyr.com/plugins/bulletproof-security/badge.svg" alt="BulletProof Security vulnerability status"></a>