Plugins · bsk-pdf-manager · data as of 2026-11-04
Is BSK PDF Manager safe? Known vulnerabilities and latest version
- Latest version
- 3.8.2
- Last updated
- 2026-10-26
- Active installs
- 7,000+
- Known issues on record
- 8
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4
Manage your PDFs / documents by category, can be display in list, columns and dropdown. Easy to embed a PDF contnet into post / page. — by bannersky
What to do
- Update to the latest version (3.8.2). Anything older than 3.6.1 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get bsk-pdf-manager --field=version shows what you run; wp plugin update bsk-pdf-manager updates it.
Check your version
Known vulnerabilities
8 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 6.8 CVE-2026-91074 · published 2026-10-17
SQL injection in BSK PDF Manager (3.8.1 and older)
- Affected
- 3.8.1 and older
- Fixed in
- unknown
- Access needed (per CVSS)
- Needs an admin-level account
- Range from
- CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory
The BSK PDF Manager WordPress plugin through 3.8.1 does not properly sanitise and escape a parameter before using it in a SQL statement, which could allow authenticated users with contributor-level access and above to perform SQL injection attacks and read sensitive data such as administrator password hashes from the database.
high 7.1 CVE-2026-108498 · published 2026-10-15
Stored cross-site scripting (XSS) in BSK PDF Manager (3.8.1 and older)
- Affected
- 3.8.1 and older
- Fixed in
- unknown
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in bannersky BSK PDF Manager bsk-pdf-manager allows Stored XSS.This issue affects BSK PDF Manager: from n/a through 3.8.1.
medium 6.5 CVE-2026-65528 · published 2026-07-23
Cross-site scripting (XSS) in BSK PDF Manager (3.8 and older)
- Affected
- 3.8 and older
- Fixed in
- unknown
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Contributor Cross Site Scripting (XSS) in BSK PDF Manager <= 3.8 versions.
medium 5.3 CVE-2026-39686 · published 2026-04-08
Information disclosure in BSK PDF Manager (3.7.2 and older)
- Affected
- 3.7.2 and older
- Fixed in
- unknown
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Exposure of Sensitive System Information to an Unauthorized Control Sphere vulnerability in bannersky BSK PDF Manager bsk-pdf-manager allows Retrieve Embedded Sensitive Data.This issue affects BSK PDF Manager: from n/a through <= 3.7.2.
medium 5.5 CVE-2025-4970 · published 2025-12-12
Stored cross-site scripting (XSS) in BSK PDF Manager (3.7.1 and older)
- Affected
- 3.7.1 and older
- Fixed in
- unknown
- Access needed (per CVSS)
- Needs an admin-level account
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The BSK PDF Manager plugin for WordPress is vulnerable to Stored Cross-Site Scripting via SVG File uploads in all versions up to, and including, 3.7.1 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Administrator-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses the SVG file. This only affects multi-site installations and installations where unfiltered_html has been disabled.
NVD CVE-2025-4970Wordfence advisoryCode change (fix)wordpress.org
medium 6.5 CVE-2024-38767 · published 2024-07-20
Stored cross-site scripting (XSS) in BSK PDF Manager (3.6 and older)
- Affected
- 3.6 and older
- Fixed in
- 3.6.1
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in BannerSky.Com BSK PDF Manager allows Stored XSS.This issue affects BSK PDF Manager: from n/a through 3.6.
medium 5.4 CVE-2023-5110 · published 2023-10-25
Stored cross-site scripting (XSS) in BSK PDF Manager (3.4.1 and older)
- Affected
- 3.4.1 and older
- Fixed in
- unknown
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
The BSK PDF Manager plugin for WordPress is vulnerable to Stored Cross-Site Scripting via 'bsk-pdfm-category-dropdown' shortcode in versions up to, and including, 3.4.1 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers with contributor-level and above permissions to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
NVD CVE-2023-5110Wordfence advisoryCode change (fix)Plugin source
high 7.2 CVE-2021-24860 · published 2021-11-29
SQL injection in BSK PDF Manager (older than 3.1.2)
- Affected
- older than 3.1.2
- Fixed in
- 3.1.2
- Access needed (per CVSS)
- Needs an admin-level account
- Range from
- NVD analysis · score by NVD
Details from the advisory
The BSK PDF Manager WordPress plugin before 3.1.2 does not validate and escape the orderby and order parameters before using them in a SQL statement, leading to a SQL injection issue
Recent activity
- 2026-10-26 — latest release on wordpress.org (3.8.2).
- 2026-10-17 — SQL injection disclosed (CVE-2026-91074), fix version not stated.
- 2026-10-15 — Stored cross-site scripting (XSS) disclosed (CVE-2026-108498), fix version not stated.
- 2026-07-23 — Cross-site scripting (XSS) disclosed (CVE-2026-65528), fix version not stated.
Get an email when BSK PDF Manager has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for BSK PDF Manager (bsk-pdf-manager) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Cross-site scripting (XSS) (5) · SQL injection (2) · Sensitive data exposure (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/bsk-pdf-manager (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/bsk-pdf-manager"><img src="https://laskyr.com/plugins/bsk-pdf-manager/badge.svg" alt="BSK PDF Manager vulnerability status"></a>