Skip to content
Laskyr

Plugins · broken-link-notifier · data as of 2026-11-04

Is Broken Link Notifier safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.0.0.3)

As of 2026-11-04. 4 issues are on record for older versions; version 2.0.0.1 or newer fixes all of them that state a fix.

Latest version
2.0.0.3
Last updated
2026-10-01
Active installs
1,000+
Known issues on record
4
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

Get notifications when a visitor loads a page with broken links — by PluginRx

What to do

  1. Update to the latest version (2.0.0.3). Anything older than 2.0.0.1 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get broken-link-notifier --field=version shows what you run; wp plugin update broken-link-notifier updates it.

Check your version

Known vulnerabilities

4 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 5.8 CVE-2026-97316 · published 2026-09-30

Server-side request forgery (SSRF) in Broken Link Notifier (1.3.1 up to (not including) 2.0.0.1)

Affected
1.3.1 up to (not including) 2.0.0.1
Fixed in
2.0.0.1
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory

The Broken Link Notifier WordPress plugin before 2.0.0.1 does not re-validate the destination of redirects when checking links, allowing unauthenticated attackers to bypass its internal-address filter and make the server send requests to internal services.

NVD CVE-2026-97316WPScan advisory

medium 5.3 CVE-2026-25408 · published 2026-02-19

Missing authorization check in Broken Link Notifier (1.3.5 and older)

Affected
1.3.5 and older
Fixed in
1.3.6
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in PluginRx Broken Link Notifier broken-link-notifier allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Broken Link Notifier: from n/a through <= 1.3.5.

NVD CVE-2026-25408Patchstack advisory

medium 4.1 CVE-2025-6838 · published 2025-07-11

CSV injection in Broken Link Notifier (1.3.0 and older)

Affected
1.3.0 and older
Fixed in
1.3.7.6 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Broken Link Notifier plugin for WordPress is vulnerable to CSV Injection in all versions up to, and including, 1.3.0 via broken links that are later exported. This makes it possible for authenticated attackers, with Contributor-level access and above, to embed untrusted input into exported CSV files, which can result in code execution when these files are downloaded and opened on a local system with a vulnerable configuration.

NVD CVE-2025-6838Wordfence advisoryCode change (fix)

medium 6.5 CVE-2025-6851 · published 2025-07-11

Server-side request forgery (SSRF) in Broken Link Notifier (1.3.0 and older)

Affected
1.3.0 and older
Fixed in
1.3.7.6 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The Broken Link Notifier plugin for WordPress is vulnerable to Server-Side Request Forgery in all versions up to, and including, 1.3.0 via the ajax_blinks() function which ultimately calls the check_url_status_code() function. This makes it possible for unauthenticated attackers to make web requests to arbitrary locations originating from the web application and can be used to query and modify information from internal services.

NVD CVE-2025-6851Wordfence advisoryCode change (fix)

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Broken Link Notifier vulnerability status badge
<a href="https://laskyr.com/plugins/broken-link-notifier"><img src="https://laskyr.com/plugins/broken-link-notifier/badge.svg" alt="Broken Link Notifier vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit