Skip to content
Laskyr

Plugins · brid-video-easy-publish · data as of 2026-11-04

Is Target Video Easy Publish safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (3.9.1)

As of 2026-11-04. 5 issues are on record for older versions; version 3.9.0 or newer fixes all of them that state a fix.

Latest version
3.9.1
Last updated
2026-11-02
Active installs
40+
Known issues on record
5
Unpatched in latest
0
Tested up to WP
7.1.4

Seamlessly embed your videos (YouTube, streaming, HTML5, Flash) using TargetVideo video players into your WordPress site or blog. — by Nebojsa

What to do

  1. Update to the latest version (3.9.1). Anything older than 3.9.0 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get brid-video-easy-publish --field=version shows what you run; wp plugin update brid-video-easy-publish updates it.

Check your version

Known vulnerabilities

5 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.4 CVE-2025-8072 · published 2026-01-28

Stored cross-site scripting (XSS) in Target Video Easy Publish (3.8.8 and older)

Affected
3.8.8 and older
Fixed in
3.8.9 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Target Video Easy Publish plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘placeholder_img’ parameter in all versions up to, and including, 3.8.8 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2025-8072Wordfence advisoryCode change (fix)wordpress.orgPlugin source

medium 5.4 CVE-2025-32688 · published 2025-09-09

Missing authorization check in Target Video Easy Publish (3.8.9 and older)

Affected
3.8.9 and older
Fixed in
3.9.0 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in Nebojsa Target Video Easy Publish brid-video-easy-publish.This issue affects Target Video Easy Publish: from n/a through <= 3.8.9.

NVD CVE-2025-32688Patchstack advisory

medium 6.4 CVE-2025-5237 · published 2025-06-18

Stored cross-site scripting (XSS) in Target Video Easy Publish (3.8.5 and older)

Affected
3.8.5 and older
Fixed in
3.8.6 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Target Video Easy Publish plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘width’ parameter in all versions up to, and including, 3.8.5 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2025-5237Wordfence advisoryCode change (fix)wordpress.orgPlugin source

medium 6.4 CVE-2024-13561 · published 2025-01-29

Stored cross-site scripting (XSS) in Target Video Easy Publish (3.8.3 and older)

Affected
3.8.3 and older
Fixed in
3.8.4 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Target Video Easy Publish plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's brid_override_yt shortcode in all versions up to, and including, 3.8.3 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2024-13561Wordfence advisoryCode change (fix)wordpress.orgPlugin source

medium 6.1 CVE-2024-12076 · published 2025-01-25

Cross-site request forgery (CSRF) in Target Video Easy Publish (3.8.3 and older)

Affected
3.8.3 and older
Fixed in
3.8.4 *
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Target Video Easy Publish plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 3.8.3. This is due to missing or incorrect nonce validation on the resync_carousel(), seek_snapshot(), uploaded_cc(), and remove_cc() functions. This makes it possible for unauthenticated attackers to inject malicious web scripts via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.

NVD CVE-2024-12076Wordfence advisoryCode change (fix)wordpress.orgPlugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Target Video Easy Publish vulnerability status badge
<a href="https://laskyr.com/plugins/brid-video-easy-publish"><img src="https://laskyr.com/plugins/brid-video-easy-publish/badge.svg" alt="Target Video Easy Publish vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit