Skip to content
Laskyr

Plugins · bricksable · data as of 2026-11-04

Is Bricksable for Bricks Builder safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.6.85)

As of 2026-11-04. 2 issues are on record for older versions; version 1.6.84 or newer fixes all of them that state a fix.

Latest version
1.6.85
Last updated
2026-10-30
Active installs
10,000+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

Elevate your website game with the Bricksable collection of premium elements for Bricks Builder. Designed to speed up your workflow, our customizable … — by Bricksable

What to do

  1. Update to the latest version (1.6.85). Anything older than 1.6.84 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get bricksable --field=version shows what you run; wp plugin update bricksable updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 5.9 CVE-2026-56009 · published 2026-06-18

Stored cross-site scripting (XSS) in Bricksable for Bricks Builder (1.6.83 and older)

Affected
1.6.83 and older
Fixed in
1.6.84
Access needed (per CVSS)
Needs an admin-level account; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Bricksable for Bricks Builder allows Stored XSS. This issue affects Bricksable for Bricks Builder: from n/a through 1.6.83.

NVD CVE-2026-56009Patchstack advisory

medium 4.8 CVE-2024-51663 · published 2024-11-09

Stored cross-site scripting (XSS) in Bricksable for Bricks Builder (1.6.59 and older)

Affected
1.6.59 and older
Fixed in
1.6.60
Access needed (per CVSS)
Needs an admin-level account; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Bricksable Bricksable for Bricks Builder bricksable allows Stored XSS.This issue affects Bricksable for Bricks Builder: from n/a through <= 1.6.59.

NVD CVE-2024-51663Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Bricksable for Bricks Builder vulnerability status badge
<a href="https://laskyr.com/plugins/bricksable"><img src="https://laskyr.com/plugins/bricksable/badge.svg" alt="Bricksable for Bricks Builder vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit