Skip to content
Laskyr

Plugins · breadcrumb-navxt · data as of 2026-11-01

Is Breadcrumb NavXT safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (7.5.2)

As of 2026-11-01. 2 issues are on record for older versions; version 7.5.2 or newer fixes all of them that state a fix.

Latest version
7.5.2
Last updated
2026-08-29
Active installs
800,000+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.0+

Adds breadcrumb navigation showing the visitor's path to their current location. — by John Havlik

What to do

  1. Update to the latest version (7.5.2). Anything older than 7.5.2 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get breadcrumb-navxt --field=version shows what you run; wp plugin update breadcrumb-navxt updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 7.1 CVE-2026-84765 · published 2026-09-03

Cross-site scripting (XSS) in Breadcrumb NavXT (7.5.1 and older)

Affected
7.5.1 and older
Fixed in
7.5.2
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Unauthenticated Cross Site Scripting (XSS) in Breadcrumb NavXT <= 7.5.1 versions.

NVD CVE-2026-84765Patchstack advisory

medium 5.3 CVE-2025-13842 · published 2026-02-19

Missing authorization check in Breadcrumb NavXT (7.5.0 and older)

Affected
7.5.0 and older
Fixed in
7.5.1 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Breadcrumb NavXT plugin for WordPress is vulnerable to authorization bypass through user-controlled key in versions up to and including 7.5.0. This is due to the Gutenberg block renderer trusting the $_REQUEST['post_id'] parameter without verification in the includes/blocks/build/breadcrumb-trail/render.php file. This makes it possible for unauthenticated attackers to enumerate and view breadcrumb trails for draft or private posts by manipulating the post_id parameter, revealing post titles and hierarchy that should remain hidden.

NVD CVE-2025-13842Wordfence advisoryCode change (fix)Plugin source

Recent activity

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Breadcrumb NavXT vulnerability status badge
<a href="https://laskyr.com/plugins/breadcrumb-navxt"><img src="https://laskyr.com/plugins/breadcrumb-navxt/badge.svg" alt="Breadcrumb NavXT vulnerability status"></a>

← Check another plugin · Free hacked-site scan

Site hacked? Get help now
Run free scan Fix it now ($499) Send a message

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit