Skip to content
Laskyr

Plugins · bread-butter · data as of 2026-11-04

Is Bread & Butter safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (9.8.0.230)

As of 2026-11-04. 3 issues are on record for older versions; version 7.5.880 or newer fixes all of them that state a fix.

Latest version
9.8.0.230
Last updated
2026-10-25
Active installs
60+
Known issues on record
3
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

Turn anonymous website traffic into named, verified, scored leads. Works with the forms you already have. One plugin, nothing to rebuild. — by Bread & Butter

What to do

  1. Update to the latest version (9.8.0.230). Anything older than 7.5.880 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get bread-butter --field=version shows what you run; wp plugin update bread-butter updates it.

Check your version

Known vulnerabilities

3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.4 CVE-2026-4279 · published 2026-04-22

Stored cross-site scripting (XSS) in Bread & Butter (8.2.0.25 and older)

Affected
8.2.0.25 and older
Fixed in
unknown
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Bread & Butter plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'breadbutter-customevent-button' shortcode in all versions up to, and including, 8.2.0.25. This is due to insufficient input sanitization and output escaping on the 'event' shortcode attribute. The customEventShortCodeButton() function takes the 'event' attribute value and directly interpolates it into a JavaScript string within an onclick HTML attribute without applying esc_attr() or esc_js(). Notably, the sister function customEventShortCode() properly uses esc_js() for the same attribute, but this was omitted in the button variant. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses the page and clicks the injected button.

NVD CVE-2026-4279Wordfence advisoryPlugin source

high 8.8 CVE-2025-12189 · published 2025-12-05

Cross-site request forgery (CSRF) in Bread & Butter (7.11.1374 and older)

Affected
7.11.1374 and older
Fixed in
unknown
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The Bread & Butter: Gate content + Capture leads + Collect first-party data + Nurture with Ai agents plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 7.11.1374. This is due to missing or incorrect nonce validation on the uploadImage() function. This makes it possible for unauthenticated attackers to upload arbitrary files that make remote code execution possible via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.

NVD CVE-2025-12189Wordfence advisoryCode change (fix)github.comryankozak.comPlugin source

medium 6.5 CVE-2024-51802 · published 2024-11-19

Cross-site scripting (XSS) in Bread & Butter (7.4.857 and older)

Affected
7.4.857 and older
Fixed in
7.5.880
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Bread & Butter Bread & Butter bread-butter allows DOM-Based XSS.This issue affects Bread & Butter: from n/a through <= 7.4.857.

NVD CVE-2024-51802Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Bread & Butter vulnerability status badge
<a href="https://laskyr.com/plugins/bread-butter"><img src="https://laskyr.com/plugins/bread-butter/badge.svg" alt="Bread & Butter vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit