Skip to content
Laskyr

Plugins · brave-popup-builder · data as of 2026-11-04

Is Brave safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (0.8.9)

As of 2026-11-04. 6 issues are on record for older versions; version 0.8.9 or newer fixes all of them that state a fix.

Latest version
0.8.9
Last updated
2026-10-28
Active installs
20,000+
Known issues on record
6
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.2.24+

The best drag-and-drop Popup Builder for WordPress. Create Popups, exit-intent popups, slide-ins, and lead generation forms & Woocommerce popups i … — by Brave

What to do

  1. Update to the latest version (0.8.9). Anything older than 0.8.9 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get brave-popup-builder --field=version shows what you run; wp plugin update brave-popup-builder updates it.

Check your version

Known vulnerabilities

6 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 5.3 CVE-2026-48202 · published 2026-10-29

Cross-site scripting (XSS) in Brave (0.8.8 and older)

Affected
0.8.8 and older
Fixed in
0.8.9
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Script-Related HTML Tags in a Web Page (Basic XSS) vulnerability in Brave Brave brave-popup-builder allows Code Injection.This issue affects Brave: from n/a through 0.8.8.

NVD CVE-2026-48202Patchstack advisory

medium 5.3 CVE-2025-68508 · published 2025-12-24

Missing authorization check in Brave (0.8.3 and older)

Affected
0.8.3 and older
Fixed in
0.8.4
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in Brave Brave brave-popup-builder allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Brave: from n/a through <= 0.8.3.

NVD CVE-2025-68508Patchstack advisory

medium 4.3 CVE-2024-43337 · published 2024-08-26

Cross-site request forgery (CSRF) in Brave (0.7.0 and older)

Affected
0.7.0 and older
Fixed in
0.7.1
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Cross-Site Request Forgery (CSRF) vulnerability in Brave Brave Popup Builder.This issue affects Brave Popup Builder: from n/a through 0.7.0.

NVD CVE-2024-43337Patchstack advisory

medium 4.8 CVE-2024-35655 · published 2024-06-04

Cross-site scripting (XSS) in Brave (0.6.9 and older)

Affected
0.6.9 and older
Fixed in
0.7.0
Access needed (per CVSS)
Needs an admin-level account; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Brave Brave brave-popup-builder allows DOM-Based XSS.This issue affects Brave: from n/a through <= 0.6.9.

NVD CVE-2024-35655Patchstack advisoryPatchstack advisory

medium 5.4 CVE-2024-30453 · published 2024-03-29

Server-side request forgery (SSRF) in Brave (0.6.5 and older)

Affected
0.6.5 and older
Fixed in
0.6.6
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Server-Side Request Forgery (SSRF) vulnerability in Brave Brave Popup Builder.This issue affects Brave Popup Builder: from n/a through 0.6.5.

NVD CVE-2024-30453Patchstack advisory

medium 4.8 CVE-2023-51534 · published 2024-02-01

Stored cross-site scripting (XSS) in Brave (0.6.2 and older)

Affected
0.6.2 and older
Fixed in
0.6.3
Access needed (per CVSS)
Needs an admin-level account; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Brave Brave – Create Popup, Optins, Lead Generation, Survey, Sticky Elements & Interactive Content allows Stored XSS.This issue affects Brave – Create Popup, Optins, Lead Generation, Survey, Sticky Elements & Interactive Content: from n/a through 0.6.2.

NVD CVE-2023-51534Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Brave vulnerability status badge
<a href="https://laskyr.com/plugins/brave-popup-builder"><img src="https://laskyr.com/plugins/brave-popup-builder/badge.svg" alt="Brave vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit