Skip to content
Laskyr

Plugins · brands-for-woocommerce · data as of 2026-11-04

Is Brands for WooCommerce safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (3.9)

As of 2026-11-04. 6 issues are on record for older versions; version 3.8.8.1 or newer fixes all of them that state a fix.

Latest version
3.9
Last updated
2026-10-23
Active installs
5,000+
Known issues on record
6
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

Brands for WooCommerce plugin allows you to add brands for products in your shop. — by BeRocket

What to do

  1. Update to the latest version (3.9). Anything older than 3.8.8.1 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get brands-for-woocommerce --field=version shows what you run; wp plugin update brands-for-woocommerce updates it.

Check your version

Known vulnerabilities

6 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.4 CVE-2026-15648 · published 2026-07-24

Stored cross-site scripting (XSS) in Brands for WooCommerce (3.8.8 and older)

Affected
3.8.8 and older
Fixed in
3.8.8.1 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Brands for WooCommerce plugin for WordPress is vulnerable to Stored Cross-Site Scripting via 'width' Shortcode Attribute in all versions up to, and including, 3.8.8 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2026-15648Wordfence advisoryCode change (fix)Plugin source

medium 6.4 CVE-2026-15646 · published 2026-07-23

Stored cross-site scripting (XSS) in Brands for WooCommerce (3.8.8 and older)

Affected
3.8.8 and older
Fixed in
3.8.8.1 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Brands for WooCommerce plugin for WordPress is vulnerable to Stored Cross-Site Scripting via 'style' Shortcode Attribute in all versions up to, and including, 3.8.8 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2026-15646Wordfence advisoryCode change (fix)Plugin source

medium 4.4 CVE-2026-15647 · published 2026-07-23

Stored cross-site scripting (XSS) in Brands for WooCommerce (3.8.8 and older)

Affected
3.8.8 and older
Fixed in
3.8.8.1 *
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Brands for WooCommerce plugin for WordPress is vulnerable to Stored Cross-Site Scripting via 'br_brand_tooltip' Term Meta Field in all versions up to, and including, 3.8.8 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with custom-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. Because the payload is stored in term meta rather than post content, the WordPress unfiltered_html capability exception does not apply, meaning Shop Manager-level users — who normally lack unfiltered_html — can fully exploit this vulnerability.

NVD CVE-2026-15647Wordfence advisoryCode change (fix)Plugin source

high 8.5 CVE-2025-68519 · published 2025-12-24

SQL injection in Brands for WooCommerce (3.8.6.3 and older)

Affected
3.8.6.3 and older
Fixed in
3.8.6.4
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in BeRocket Brands for WooCommerce brands-for-woocommerce allows Blind SQL Injection.This issue affects Brands for WooCommerce: from n/a through <= 3.8.6.3.

NVD CVE-2025-68519Patchstack advisory

medium 5.3 CVE-2023-44149 · published 2024-12-13

Missing authorization check in Brands for WooCommerce (3.8.2.2 and older)

Affected
3.8.2.2 and older
Fixed in
3.8.2.3
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in BeRocket Brands for WooCommerce brands-for-woocommerce allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Brands for WooCommerce: from n/a through <= 3.8.2.2.

NVD CVE-2023-44149Patchstack advisory

medium 5.4 CVE-2023-23667 · published 2023-05-18

Stored cross-site scripting (XSS) in Brands for WooCommerce (3.7.0.6 and older)

Affected
3.7.0.6 and older
Fixed in
3.8.2
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Auth. (contributor+) Stored Cross-Site Scripting (XSS) vulnerability in BeRocket Brands for WooCommerce plugin <= 3.7.0.6 versions.

NVD CVE-2023-23667Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Brands for WooCommerce vulnerability status badge
<a href="https://laskyr.com/plugins/brands-for-woocommerce"><img src="https://laskyr.com/plugins/brands-for-woocommerce/badge.svg" alt="Brands for WooCommerce vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit