Skip to content
Laskyr

Plugins · branda-white-labeling · data as of 2026-11-04

Is Branda safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (3.4.33)

As of 2026-11-04. 8 issues are on record for older versions; version 3.4.33 or newer fixes all of them that state a fix.

Latest version
3.4.33
Last updated
2026-09-28
Active installs
10,000+
Known issues on record
8
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

White label & rebrand your login page & WordPress dashboard. Customize system emails & get everything to rebrand WordPress with Branda. — by WPMU DEV - Your All-in-One WordPress Platform

What to do

  1. Update to the latest version (3.4.33). Anything older than 3.4.33 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get branda-white-labeling --field=version shows what you run; wp plugin update branda-white-labeling updates it.

Check your version

Known vulnerabilities

8 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 7.1 CVE-2026-102376 · published 2026-09-30

Cross-site scripting (XSS) in Branda (3.4.32 and older)

Affected
3.4.32 and older
Fixed in
3.4.33
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Subscriber Cross Site Scripting (XSS) in Branda <= 3.4.32 versions.

NVD CVE-2026-102376Patchstack advisory

critical 9.8 CVE-2026-11551 · published 2026-06-20

Privilege escalation in Branda (3.4.29 and older)

Affected
3.4.29 and older
Fixed in
3.4.31 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Branda plugin for WordPress is vulnerable to privilege escalation via account takeover in all versions up to, and including, 3.4.29. This is due to the plugin not properly validating a user's identity prior to updating their password. This makes it possible for unauthenticated attackers to change arbitrary user's passwords, including administrators, and leverage that to gain access to their account.

NVD CVE-2026-11551Wordfence advisoryCode change (fix)Plugin source

critical 9.8 CVE-2025-14998 · published 2026-01-02

Privilege escalation in Branda (3.4.24 and older)

Affected
3.4.24 and older
Fixed in
3.4.25 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Branda plugin for WordPress is vulnerable to privilege escalation via account takeover in all versions up to, and including, 3.4.24. This is due to the plugin not properly validating a user's identity prior to updating their password. This makes it possible for unauthenticated attackers to change arbitrary user's passwords, including administrators, and leverage that to gain access to their account.

NVD CVE-2025-14998Wordfence advisoryCode change (fix)Plugin source

medium 6.1 CVE-2024-9371 · published 2024-11-21

Reflected cross-site scripting (XSS) in Branda (3.4.21 and older)

Affected
3.4.21 and older
Fixed in
3.4.22 *
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Branda – White Label & Branding, Custom Login Page Customizer plugin for WordPress is vulnerable to Reflected Cross-Site Scripting due to the use of remove_query_arg without appropriate escaping on the URL in all versions up to, and including, 3.4.19. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link.

NVD CVE-2024-9371Wordfence advisoryCode change (fix)Plugin source

medium 4.8 CVE-2024-37239 · published 2024-07-22

Cross-site scripting (XSS) in Branda (3.4.17 and older)

Affected
3.4.17 and older
Fixed in
3.4.18
Access needed (per CVSS)
Needs an admin-level account; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in WPMU DEV - Your All-in-One WordPress Platform Branda branda-white-labeling.This issue affects Branda: from n/a through <= 3.4.17.

NVD CVE-2024-37239Patchstack advisoryPatchstack advisory

medium 5.3 CVE-2024-6554 · published 2024-07-11

Information disclosure in Branda (3.4.18 and older)

Affected
3.4.18 and older
Fixed in
3.4.19 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Branda – White Label WordPress, Custom Login Page Customizer plugin for WordPress is vulnerable to Full Path Disclosure in all versions up to, and including, 3.4.18. This is due the plugin utilizing composer without preventing direct access to the files. This makes it possible for unauthenticated attackers to retrieve the full path of the web application, which can be used to aid other attacks. The information displayed is not useful on its own, and requires another vulnerability to be present for damage to an affected website.

NVD CVE-2024-6554Wordfence advisoryCode change (fix)Plugin source

medium 5.4 CVE-2024-5191 · published 2024-06-21

Stored cross-site scripting (XSS) in Branda (3.4.17 and older)

Affected
3.4.17 and older
Fixed in
3.4.18 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The Branda – White Label WordPress, Custom Login Page Customizer plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘mime_types’ parameter in all versions up to, and including, 3.4.17 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Author-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2024-5191Wordfence advisoryCode change (fix)Plugin source

medium 5.3 CVE-2023-51542 · published 2024-06-04

Authentication bypass in Branda (3.4.14 and older)

Affected
3.4.14 and older
Fixed in
3.4.15
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Authentication Bypass by Spoofing vulnerability in WPMU DEV Branda allows Accessing Functionality Not Properly Constrained by ACLs.This issue affects Branda: from n/a through 3.4.14.

NVD CVE-2023-51542Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Branda vulnerability status badge
<a href="https://laskyr.com/plugins/branda-white-labeling"><img src="https://laskyr.com/plugins/branda-white-labeling/badge.svg" alt="Branda vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit