Skip to content
Laskyr

Plugins · bp-groupblog · data as of 2026-11-04

Is BuddyPress Groupblog safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.9.4)

As of 2026-11-04. 1 issue is on record for older versions; version 1.9.4 or newer fixes all of them that state a fix.

Latest version
1.9.4
Last updated
2026-03-30
Active installs
50+
Known issues on record
1
Unpatched in latest
0
Tested up to WP
7.0.8

BuddyPress Groupblog extends the group functionality by enabling the group to have a single blog associated with it. — by Boone Gorges

What to do

  1. Update to the latest version (1.9.4). Anything older than 1.9.4 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get bp-groupblog --field=version shows what you run; wp plugin update bp-groupblog updates it.

Check your version

Known vulnerabilities

1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 8.8 CVE-2026-5144 · published 2026-04-11

Privilege escalation in BuddyPress Groupblog (1.9.3 and older)

Affected
1.9.3 and older
Fixed in
1.9.4 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The BuddyPress Groupblog plugin for WordPress is vulnerable to Privilege Escalation in all versions up to, and including, 1.9.3. This is due to the group blog settings handler accepting the `groupblog-blogid`, `default-member`, and `groupblog-silent-add` parameters from user input without proper authorization checks. The `groupblog-blogid` parameter allows any group admin (including Subscribers who create their own group) to associate their group with any blog on the Multisite network, including the main site (blog ID 1). The `default-member` parameter accepts any WordPress role, including `administrator`, without validation against a whitelist. When combined with `groupblog-silent-add`, any user who joins the attacker's group is automatically added to the targeted blog with the injected role. This makes it possible for authenticated attackers, with Subscriber-level access and above, to escalate any user (including themselves via a second account) to Administrator on the main site of the Multisite network.

NVD CVE-2026-5144Wordfence advisorygithub.comPlugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
BuddyPress Groupblog vulnerability status badge
<a href="https://laskyr.com/plugins/bp-groupblog"><img src="https://laskyr.com/plugins/bp-groupblog/badge.svg" alt="BuddyPress Groupblog vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit