Skip to content
Laskyr

Plugins · bookster · data as of 2026-11-04

Is Bookster safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (3.3.0)

As of 2026-11-04. 2 issues are on record for older versions; version 2.2.0 or newer fixes all of them that state a fix.

Latest version
3.3.0
Last updated
2026-09-03
Active installs
100+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

Manage real-time bookings with ease. Multi-step booking form, multiple services and locations, built-in customer dashboard. — by Bookster

What to do

  1. Update to the latest version (3.3.0). Anything older than 2.2.0 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get bookster --field=version shows what you run; wp plugin update bookster updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 4.9 CVE-2025-8781 · published 2026-02-18

SQL injection in Bookster (2.1.1 and older)

Affected
2.1.1 and older
Fixed in
2.2.0 *
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Bookster – WordPress Appointment Booking Plugin plugin for WordPress is vulnerable to SQL Injection via the ‘raw’ parameter in all versions up to, and including, 2.1.1 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for authenticated attackers, with Administrator-level access and above, to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database.

NVD CVE-2025-8781Wordfence advisoryCode change (fix)Plugin source

medium 6.5 CVE-2024-5071 · published 2024-06-26

Missing authorization check in Bookster (1.1.0 and older)

Affected
1.1.0 and older
Fixed in
1.2.0 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory

The Bookster WordPress plugin through 1.1.0 allows adding sensitive parameters when validating appointments allowing attackers to manipulate the data sent when booking an appointment (the request body) to change its status from pending to approved.

NVD CVE-2024-5071WPScan advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Bookster vulnerability status badge
<a href="https://laskyr.com/plugins/bookster"><img src="https://laskyr.com/plugins/bookster/badge.svg" alt="Bookster vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit