Skip to content
Laskyr

Plugins · booking-system-trafft · data as of 2026-11-04

Is Booking System Trafft safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.0.19)

As of 2026-11-04. 3 issues are on record for older versions; version 1.0.15 or newer fixes all of them that state a fix.

Latest version
1.0.19
Last updated
2026-09-29
Active installs
400+
Known issues on record
3
Unpatched in latest
0
Tested up to WP
7.0.8 · PHP 7.4+

Trafft is a next-level booking system offering limitless opportunities for scheduling appointments and managing your calendar & all of your bookings. — by Melograno Venture Studio

What to do

  1. Update to the latest version (1.0.19). Anything older than 1.0.15 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get booking-system-trafft --field=version shows what you run; wp plugin update booking-system-trafft updates it.

Check your version

Known vulnerabilities

3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.4 CVE-2026-8791 · published 2026-07-29

Stored cross-site scripting (XSS) in Booking System Trafft (1.0.17 and older)

Affected
1.0.17 and older
Fixed in
unknown
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
advisory text · score by Wordfence
Details from the advisory

The Booking System Trafft plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the `bookingWebsiteUrl` setting in all versions up to, and including, 1.0.17 due to a missing capability check on the `set_options` AJAX action when the plugin is operating in agency mode. The `trafftSetOptions()` handler verifies a nonce that is exposed to any authenticated user (it is printed inline on every admin page, including profile.php) but performs no capability check before calling `update_option('trafft_option', ['bookingWebsiteUrl' => ...])`. This setting is then used by `trafftAdminAssets()` to enqueue `<bookingWebsiteUrl>/embed.js` as a script on every front-end page that renders the booking shortcode. This makes it possible for authenticated attackers, with Subscriber-level access and above, to point the embed-script URL at an attacker-controlled origin and execute arbitrary JavaScript in the browser of every site visitor (including admins).

NVD CVE-2026-8791Wordfence advisoryPlugin source

medium 6.5 CVE-2025-58213 · published 2025-08-27

Stored cross-site scripting (XSS) in Booking System Trafft (1.0.14 and older)

Affected
1.0.14 and older
Fixed in
1.0.15
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in ameliabooking Booking System Trafft booking-system-trafft allows Stored XSS.This issue affects Booking System Trafft: from n/a through <= 1.0.14.

NVD CVE-2025-58213Patchstack advisory

medium 6.4 CVE-2024-11754 · published 2024-12-13

Stored cross-site scripting (XSS) in Booking System Trafft (1.0.6 and older)

Affected
1.0.6 and older
Fixed in
unknown
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Booking System Trafft plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's 'trafftbooking' shortcode in all versions up to, and including, 1.0.6 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2024-11754Wordfence advisoryCode change (fix)

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Booking System Trafft vulnerability status badge
<a href="https://laskyr.com/plugins/booking-system-trafft"><img src="https://laskyr.com/plugins/booking-system-trafft/badge.svg" alt="Booking System Trafft vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit