Plugins · booking-manager · data as of 2026-11-04
Is Booking Manager safe? Known vulnerabilities and latest version
- Latest version
- 2.1.22
- Last updated
- 2026-09-21
- Active installs
- 5,000+
- Known issues on record
- 7
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 5.6+
Showing events listing from .ics feeds or sync bookings from different sources to your website — by wpdevelop
What to do
- Update to the latest version (2.1.22). Anything older than 2.1.21 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get booking-manager --field=version shows what you run; wp plugin update booking-manager updates it.
Check your version
Known vulnerabilities
7 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 6.8 CVE-2026-91024 · published 2026-09-23
SQL injection in Booking Manager (older than 2.1.21)
- Affected
- older than 2.1.21
- Fixed in
- 2.1.21
- Access needed (per CVSS)
- Needs an admin-level account
- Range from
- CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory
The Booking Manager WordPress plugin before 2.1.21 does not sanitize and escape values taken from a fetched external iCalendar feed before using them in a SQL query, allowing authenticated users with Author-level access and above to perform SQL injection attacks by importing a feed they control.
medium 4.3 CVE-2026-91025 · published 2026-09-23
Missing authorization check in Booking Manager (older than 2.1.21)
- Affected
- older than 2.1.21
- Fixed in
- 2.1.21
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory
The Booking Manager WordPress plugin before 2.1.21 does not verify that a request to modify a user's Booking Manager WordPress plugin before 2.1.21-specific settings targets the requesting user's own account, allowing any authenticated user with subscriber-level access and above to create or overwrite the Booking Manager WordPress plugin before 2.1.21's per-user settings on arbitrary users, including administrators.
medium 6.5 CVE-2026-42751 · published 2026-05-27
Stored cross-site scripting (XSS) in Booking Manager (2.1.18 and older)
- Affected
- 2.1.18 and older
- Fixed in
- 2.1.19
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in wpdevelop Booking Manager booking-manager allows Stored XSS.This issue affects Booking Manager: from n/a through <= 2.1.18.
medium 6.5 CVE-2025-64275 · published 2025-11-13
Stored cross-site scripting (XSS) in Booking Manager (2.1.17 and older)
- Affected
- 2.1.17 and older
- Fixed in
- 2.1.18
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in wpdevelop Booking Manager booking-manager allows Stored XSS.This issue affects Booking Manager: from n/a through <= 2.1.17.
medium 4.5 CVE-2025-10124 · published 2025-10-10
Security issue in Booking Manager (older than 2.1.15)
- Affected
- older than 2.1.15
- Fixed in
- 2.1.15
- Access needed (per CVSS)
- Needs an admin-level account; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory
The Booking Manager WordPress plugin before 2.1.15 registers a shortcode that deletes bookings and makes that shortcode available to anyone with contributor and above privileges. When a page containing the shortcode is visited, the bookings are deleted.
high 8.8 CVE-2023-50840 · published 2023-12-28
SQL injection in Booking Manager (2.1.5 and older)
- Affected
- 2.1.5 and older
- Fixed in
- 2.1.6
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in wpdevelop, oplugins Booking Manager.This issue affects Booking Manager: from n/a through 2.1.5.
high 8.8 CVE-2023-1977 · published 2023-08-16
Server-side request forgery (SSRF) in Booking Manager (older than 2.0.29)
- Affected
- older than 2.0.29
- Fixed in
- 2.0.29
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
The Booking Manager WordPress plugin before 2.0.29 does not validate URLs input in it's admin panel or in shortcodes for showing events from a remote .ics file, allowing an attacker with privileges as low as Subscriber to perform SSRF attacks on the sites internal network.
Recent activity
- 2026-09-21 — latest release on wordpress.org (2.1.22).
- 2026-09-23 — SQL injection disclosed (CVE-2026-91024), fixed in 2.1.21.
- 2026-09-23 — Missing authorization check disclosed (CVE-2026-91025), fixed in 2.1.21.
- 2026-05-27 — Stored cross-site scripting (XSS) disclosed (CVE-2026-42751), fixed in 2.1.19.
Get an email when Booking Manager has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Booking Manager (booking-manager) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by wpdevelop (2 tracked)
Types found in this plugin: SQL injection (2) · Cross-site scripting (XSS) (2) · Missing authorization (1) · Server-side request forgery (SSRF) (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/booking-manager (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/booking-manager"><img src="https://laskyr.com/plugins/booking-manager/badge.svg" alt="Booking Manager vulnerability status"></a>