Skip to content
Laskyr

Plugins · booking-calendar-contact-form · data as of 2026-11-04

Is Booking Calendar Contact Form safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.2.68)

As of 2026-11-04. 8 issues are on record for older versions; version 1.2.64 or newer fixes all of them that state a fix.

Latest version
1.2.68
Last updated
2026-10-27
Active installs
500+
Known issues on record
8
Unpatched in latest
0
Tested up to WP
7.1.4

Booking calendar form with a start and end date, or a single date option. Perfect for hotels, houses, services. PayPal payment integration included. — by codepeople

What to do

  1. Update to the latest version (1.2.68). Anything older than 1.2.64 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get booking-calendar-contact-form --field=version shows what you run; wp plugin update booking-calendar-contact-form updates it.

Check your version

Known vulnerabilities

8 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 5.3 CVE-2026-6810 · published 2026-04-24

Missing authorization check in Booking Calendar Contact Form (1.2.63 and older)

Affected
1.2.63 and older
Fixed in
1.2.64 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Booking Calendar Contact Form plugin for WordPress is vulnerable to Insecure Direct Object Reference in all versions up to, and including, 1.2.63 via the dex_bccf_admin_int_calendar_list.inc.php file due to missing validation on a user controlled key. This makes it possible for authenticated attackers, with Subscriber-level access and above, to takeover other user's calendars and view user data associated with the calendar.

NVD CVE-2026-6810Wordfence advisoryCode change (fix)Plugin source

medium 5.3 CVE-2025-13318 · published 2025-11-22

Missing authorization check in Booking Calendar Contact Form (1.2.60 and older)

Affected
1.2.60 and older
Fixed in
1.2.61 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Booking Calendar Contact Form plugin for WordPress is vulnerable to Missing Authorization in all versions up to, and including, 1.2.60. This is due to missing authorization checks and payment verification in the `dex_bccf_check_IPN_verification` function. This makes it possible for unauthenticated attackers to arbitrarily confirm bookings and bypass payment requirements via the 'dex_bccf_ipn' parameter.

NVD CVE-2025-13318Wordfence advisoryCode change (fix)Plugin source

medium 6.5 CVE-2025-48231 · published 2025-07-04

Stored cross-site scripting (XSS) in Booking Calendar Contact Form (1.2.58 and older)

Affected
1.2.58 and older
Fixed in
1.2.59
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in codepeople Booking Calendar Contact Form booking-calendar-contact-form allows Stored XSS.This issue affects Booking Calendar Contact Form: from n/a through <= 1.2.58.

NVD CVE-2025-48231Patchstack advisory

medium 5.9 CVE-2025-24723 · published 2025-01-24

Stored cross-site scripting (XSS) in Booking Calendar Contact Form (1.2.55 and older)

Affected
1.2.55 and older
Fixed in
1.2.56
Access needed (per CVSS)
Needs an admin-level account; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in codepeople Booking Calendar Contact Form booking-calendar-contact-form allows Stored XSS.This issue affects Booking Calendar Contact Form: from n/a through <= 1.2.55.

NVD CVE-2025-24723Patchstack advisory

medium 4.3 CVE-2023-25037 · published 2024-12-09

Missing authorization check in Booking Calendar Contact Form (1.2.34 and older)

Affected
1.2.34 and older
Fixed in
1.2.35
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in CodePeople Booking Calendar Contact Form allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Booking Calendar Contact Form: from n/a through 1.2.34.

NVD CVE-2023-25037Patchstack advisory

medium 6.1 CVE-2023-36384 · published 2023-07-18

Reflected cross-site scripting (XSS) in Booking Calendar Contact Form (1.2.40 and older)

Affected
1.2.40 and older
Fixed in
1.2.41
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Unauth. Reflected Cross-Site Scripting (XSS) vulnerability in CodePeople Booking Calendar Contact Form plugin <= 1.2.40 versions.

NVD CVE-2023-36384Patchstack advisory

medium 6.1 CVE-2016-10908 · published 2019-08-21

Cross-site scripting (XSS) in Booking Calendar Contact Form (older than 1.0.24)

Affected
older than 1.0.24
Fixed in
1.0.24
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
NVD analysis · score by NVD
Details from the advisory

The booking-calendar-contact-form plugin before 1.0.24 for WordPress has XSS.

NVD CVE-2016-10908wordpress.org

critical 9.8 CVE-2016-10909 · published 2019-08-21

SQL injection in Booking Calendar Contact Form (older than 1.0.24)

Affected
older than 1.0.24
Fixed in
1.0.24
Access needed (per CVSS)
No login needed
Range from
NVD analysis · score by NVD
Details from the advisory

The booking-calendar-contact-form plugin before 1.0.24 for WordPress has SQL injection.

NVD CVE-2016-10909wordpress.org

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Booking Calendar Contact Form vulnerability status badge
<a href="https://laskyr.com/plugins/booking-calendar-contact-form"><img src="https://laskyr.com/plugins/booking-calendar-contact-form/badge.svg" alt="Booking Calendar Contact Form vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit