Skip to content
Laskyr

Plugins · bookeropl · data as of 2026-11-04

Is Bookero.pl safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.3)

As of 2026-11-04. 1 issue is on record for older versions.

Latest version
2.3
Last updated
2026-05-06
Active installs
1,000+
Known issues on record
1
Unpatched in latest
0
Tested up to WP
6.9.11

Wtyczka do wordpress wyświetlająca formularz systemu rezerwacji online Bookero — by safistudio

What to do

  1. Update to the latest version (2.3). Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get bookeropl --field=version shows what you run; wp plugin update bookeropl updates it.

Check your version

Known vulnerabilities

1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.4 CVE-2026-6910 · published 2026-07-09

Stored cross-site scripting (XSS) in Bookero.pl (2.2 and older)

Affected
2.2 and older
Fixed in
unknown
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Bookero.pl – system rezerwacji online plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the `bookero_products` shortcode's `hide_products` (and `filter_products`) attributes in versions up to and including 2.2. This is due to insufficient input sanitization and output escaping in the `bookero_products()` function — the raw attribute value is concatenated directly into an inline `<script>` block without any escaping. This makes it possible for authenticated attackers with contributor-level access and above to inject arbitrary web scripts into pages that will execute whenever a user accesses the injected page.

NVD CVE-2026-6910Wordfence advisoryCode change (fix)Plugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Bookero.pl vulnerability status badge
<a href="https://laskyr.com/plugins/bookeropl"><img src="https://laskyr.com/plugins/bookeropl/badge.svg" alt="Bookero.pl vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit