Plugins · bold-timeline-lite · data as of 2026-11-04
Is Bold Timeline Lite safe? Known vulnerabilities and latest version
- Latest version
- 1.3.0
- Last updated
- 2026-06-01
- Active installs
- 10,000+
- Known issues on record
- 6
- Unpatched in latest
- 0
- Tested up to WP
- 7.0.8
Bold Timeline Lite – WordPress Timeline Plugin — by boldthemes
What to do
- Update to the latest version (1.3.0). Anything older than 1.3.0 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get bold-timeline-lite --field=version shows what you run; wp plugin update bold-timeline-lite updates it.
Check your version
Known vulnerabilities
6 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 6.4 CVE-2026-7438 · published 2026-09-11
Stored cross-site scripting (XSS) in Bold Timeline Lite (1.2.8 and older)
- Affected
- 1.2.8 and older
- Fixed in
- 1.3.0 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Bold Timeline Lite plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the `supertitle` and `subtitle` attributes of the `bold_timeline_item` shortcode in all versions up to, and including, 1.2.8 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
NVD CVE-2026-7438Wordfence advisoryCode change (fix)wordpress.orgPlugin source
medium 6.5 CVE-2025-68513 · published 2025-12-24
Stored cross-site scripting (XSS) in Bold Timeline Lite (1.2.7 and older)
- Affected
- 1.2.7 and older
- Fixed in
- 1.2.8
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in boldthemes Bold Timeline Lite bold-timeline-lite allows Stored XSS.This issue affects Bold Timeline Lite: from n/a through <= 1.2.7.
medium 6.4 CVE-2025-14032 · published 2025-12-12
Stored cross-site scripting (XSS) in Bold Timeline Lite (1.2.7 and older)
- Affected
- 1.2.7 and older
- Fixed in
- 1.2.8 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Bold Timeline Lite plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'title' parameter in the 'bold_timeline_group' shortcode in all versions up to, and including, 1.2.7 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
NVD CVE-2025-14032Wordfence advisoryCode change (fix)wordpress.orgPlugin source
medium 4.3 CVE-2023-45110 · published 2025-01-02
Missing authorization check in Bold Timeline Lite (1.1.9 and older)
- Affected
- 1.1.9 and older
- Fixed in
- 1.2.0
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Missing Authorization vulnerability in boldthemes Bold Timeline Lite bold-timeline-lite allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Bold Timeline Lite: from n/a through <= 1.1.9.
medium 6.5 CVE-2024-43294 · published 2024-08-18
Stored cross-site scripting (XSS) in Bold Timeline Lite (1.2.0 and older)
- Affected
- 1.2.0 and older
- Fixed in
- 1.2.1
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in BoldThemes Bold Timeline Lite allows Stored XSS.This issue affects Bold Timeline Lite: from n/a through 1.2.0.
medium 5.4 CVE-2022-4828 · published 2023-01-30
Stored cross-site scripting (XSS) in Bold Timeline Lite (older than 1.1.5)
- Affected
- older than 1.1.5
- Fixed in
- 1.1.5
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
The Bold Timeline Lite WordPress plugin before 1.1.5 does not validate and escape some of its shortcode attributes before outputting them back in the page, which could allow users with a role as low as contributor to perform Stored Cross-Site Scripting attacks which could be used against high privilege users such as admins.
Recent activity
- 2026-06-01 — latest release on wordpress.org (1.3.0).
- 2026-09-11 — Stored cross-site scripting (XSS) disclosed (CVE-2026-7438), fixed in 1.3.0.
- 2025-12-24 — Stored cross-site scripting (XSS) disclosed (CVE-2025-68513), fixed in 1.2.8.
- 2025-12-12 — Stored cross-site scripting (XSS) disclosed (CVE-2025-14032), fixed in 1.2.8.
Get an email when Bold Timeline Lite has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Bold Timeline Lite (bold-timeline-lite) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by boldthemes (2 tracked)
Types found in this plugin: Cross-site scripting (XSS) (5) · Missing authorization (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/bold-timeline-lite (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/bold-timeline-lite"><img src="https://laskyr.com/plugins/bold-timeline-lite/badge.svg" alt="Bold Timeline Lite vulnerability status"></a>