Skip to content
Laskyr

Plugins · bnm-blocks · data as of 2026-11-04

Is Post Blocks & Tools safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.3.2)

As of 2026-11-04. 2 issues are on record for older versions; version 1.3.1 or newer fixes all of them that state a fix.

Latest version
1.3.2
Last updated
2026-08-20
Active installs
500+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.0+

Post grid, post list, and post slider Gutenberg blocks to design blog and magazine layouts easily. — by ThemezHut

What to do

  1. Update to the latest version (1.3.2). Anything older than 1.3.1 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get bnm-blocks --field=version shows what you run; wp plugin update bnm-blocks updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.4 CVE-2026-5711 · published 2026-04-08

Stored cross-site scripting (XSS) in Post Blocks & Tools (1.3.0 and older)

Affected
1.3.0 and older
Fixed in
1.3.1 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Post Blocks & Tools plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'sliderStyle' block attribute in the Posts Slider block in all versions up to, and including, 1.3.0 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with author-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2026-5711Wordfence advisoryCode change (fix)Plugin source

medium 6.4 CVE-2025-11828 · published 2025-11-11

Stored cross-site scripting (XSS) in Post Blocks & Tools (1.2.3 and older)

Affected
1.2.3 and older
Fixed in
1.2.4 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Magazine Companion plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'headerHtmlTag' attribute in the bnm-blocks/featured-posts-1 block in all versions up to, and including, 1.2.3. This is due to insufficient input sanitization and output escaping when using user-supplied values as HTML tag names. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2025-11828Wordfence advisoryCode change (fix)wordpress.orgPlugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Post Blocks & Tools vulnerability status badge
<a href="https://laskyr.com/plugins/bnm-blocks"><img src="https://laskyr.com/plugins/bnm-blocks/badge.svg" alt="Post Blocks & Tools vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit