Skip to content
Laskyr

Plugins · bne-testimonials · data as of 2026-11-04

Is BNE Testimonials safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.0.8.3)

As of 2026-11-04. 3 issues are on record for older versions; version 2.0.8.2 or newer fixes all of them that state a fix.

Latest version
2.0.8.3
Last updated
2026-10-12
Active installs
1,000+
Known issues on record
3
Unpatched in latest
0
Tested up to WP
7.0.8 · PHP 5.6+

Display testimonials and reviews on any page or widget area as list or slider. Upgrade to PRO for additional layouts, themes, submission form, API, ra … — by Kerry

What to do

  1. Update to the latest version (2.0.8.3). Anything older than 2.0.8.2 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get bne-testimonials --field=version shows what you run; wp plugin update bne-testimonials updates it.

Check your version

Known vulnerabilities

3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 5.4 CVE-2026-15245 · published 2026-08-07

Cross-site scripting (XSS) in BNE Testimonials (older than 2.0.8.2)

Affected
older than 2.0.8.2
Fixed in
2.0.8.2
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory

The BNE Testimonials WordPress plugin before 2.0.8.2 does not properly escape a shortcode attribute for a JavaScript context before echoing it into an inline script, allowing users with the contributor role and above to inject arbitrary JavaScript that executes in the browser of anyone viewing the affected content.

NVD CVE-2026-15245WPScan advisory

medium 6.5 CVE-2025-68075 · published 2026-06-26

Cross-site scripting (XSS) in BNE Testimonials (2.0.8 and older)

Affected
2.0.8 and older
Fixed in
2.0.8.1 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Contributor Cross Site Scripting (XSS) in BNE Testimonials <= 2.0.8 versions.

NVD CVE-2025-68075Patchstack advisory

medium 5.4 CVE-2023-24411 · published 2023-04-06

Stored cross-site scripting (XSS) in BNE Testimonials (2.0.7 and older)

Affected
2.0.7 and older
Fixed in
2.0.8
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Auth. (contributor+) Stored Cross-Site Scripting (XSS) vulnerability in Kerry Kline BNE Testimonials plugin <= 2.0.7 versions.

NVD CVE-2023-24411Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
BNE Testimonials vulnerability status badge
<a href="https://laskyr.com/plugins/bne-testimonials"><img src="https://laskyr.com/plugins/bne-testimonials/badge.svg" alt="BNE Testimonials vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit