Skip to content
Laskyr

Plugins · bmlt-wordpress-satellite-plugin · data as of 2026-11-04

Is BMLT WordPress Satellite safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (3.11.6)

As of 2026-11-04. 1 issue is on record for older versions; version 3.11.6 or newer fixes all of them that state a fix.

Latest version
3.11.6
Last updated
2026-03-20
Active installs
90+
Known issues on record
1
Unpatched in latest
0
Tested up to WP
6.9.11 · PHP 8.1+

This is a "satellite" plugin for the Basic Meeting List Toolbox (BMLT). — by BMLTGuy

What to do

  1. Update to the latest version (3.11.6). Anything older than 3.11.6 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get bmlt-wordpress-satellite-plugin --field=version shows what you run; wp plugin update bmlt-wordpress-satellite-plugin updates it.

Check your version

Known vulnerabilities

1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 4.3 CVE-2025-14162 · published 2025-12-12

Cross-site request forgery (CSRF) in BMLT WordPress Satellite (3.11.4 and older)

Affected
3.11.4 and older
Fixed in
3.11.6 *
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The BMLT WordPress Plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 3.11.4. This is due to missing nonce validation on the 'BMLTPlugin_create_option' and 'BMLTPlugin_delete_option ' action. This makes it possible for unauthenticated attackers to create new plugin settings via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.

NVD CVE-2025-14162Wordfence advisoryPlugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
BMLT WordPress Satellite vulnerability status badge
<a href="https://laskyr.com/plugins/bmlt-wordpress-satellite-plugin"><img src="https://laskyr.com/plugins/bmlt-wordpress-satellite-plugin/badge.svg" alt="BMLT WordPress Satellite vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit