Skip to content
Laskyr

Plugins · blue-captcha · data as of 2026-11-04

Is Blue Captcha safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.1.0)

As of 2026-11-04. 2 issues are on record for older versions; version 2.1.0 or newer fixes all of them that state a fix.

Latest version
2.1.0
Last updated
2026-08-17
Active installs
400+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
7.0.8 · PHP 7.0+

Blue Captcha is a powerful and highly customized WordPress plugin that effectively protects your WP blogs from spammers and unwanted persons. — by jotis

What to do

  1. Update to the latest version (2.1.0). Anything older than 2.1.0 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get blue-captcha --field=version shows what you run; wp plugin update blue-captcha updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 4.3 CVE-2026-10552 · published 2026-06-24

Cross-site request forgery (CSRF) in Blue Captcha (2.0.1 and older)

Affected
2.0.1 and older
Fixed in
2.1.0 *
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Blue Captcha plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions up to and including 2.0.1. This is due to missing or incorrect nonce validation on the main admin panel (blcap_main_page) and on the Hall of Shame and Log subpages, which accept a 'blcap_action' / 'action' parameter from $_REQUEST and perform destructive operations (plugin uninstall via blcap_uninstall(), log deletion via blcap_delete_logs(), Hall of Shame deletion via blcap_delete_ip_db(), and adding IPs to the banned list via update_option('blcap_settings')) with no wp_verify_nonce(), check_admin_referer(), or check_ajax_referer() calls anywhere in the codebase. This makes it possible for unauthenticated attackers to uninstall the plugin, delete audit logs, remove Hall of Shame entries, and add arbitrary IP addresses to the block list via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.

NVD CVE-2026-10552Wordfence advisoryPlugin source

high 7.1 CVE-2025-28880 · published 2025-03-26

Reflected cross-site scripting (XSS) in Blue Captcha (1.7.4 and older)

Affected
1.7.4 and older
Fixed in
2.0.0
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in jotis Blue Captcha blue-captcha allows Reflected XSS.This issue affects Blue Captcha: from n/a through <= 1.7.4.

NVD CVE-2025-28880Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Blue Captcha vulnerability status badge
<a href="https://laskyr.com/plugins/blue-captcha"><img src="https://laskyr.com/plugins/blue-captcha/badge.svg" alt="Blue Captcha vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit