Skip to content
Laskyr

Plugins · bloyal · data as of 2026-11-04

Is bLoyal safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (3.1.611.90)

As of 2026-11-04. 1 issue is on record for older versions; version 3.1.611.90 or newer fixes all of them that state a fix.

Latest version
3.1.611.90
Last updated
2026-08-21
Active installs
20+
Known issues on record
1
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

WC tested up to: 10.8.1 Requires PHP: 7.4 Stable tag: 3.1.611.90 License: GPLv2 or later License URI: https://www.gnu.org/licenses/gpl-2.0. — by bLoyal

What to do

  1. Update to the latest version (3.1.611.90). Anything older than 3.1.611.90 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get bloyal --field=version shows what you run; wp plugin update bloyal updates it.

Check your version

Known vulnerabilities

1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 8.8 CVE-2026-15001 · published 2026-08-15

Privilege escalation in bLoyal (3.1.611.78 and older)

Affected
3.1.611.78 and older
Fixed in
3.1.611.90 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The bLoyal: Loyalty & Promotions by bLoyal plugin for WordPress is vulnerable to Privilege Escalation in all versions up to, and including, 3.1.611.78. This is due to the AJAX actions `save_bloyal_configuration_data` and `save_bloyal_accesskeyverification_data` being registered without any capability or nonce checks, and the `bloyal_customer_auto_login` function unconditionally trusting the `Customer.ExternalId` value returned by whichever API URL is stored in the plugin's options. This makes it possible for authenticated attackers, with Subscriber-level access and above, to overwrite the plugin's bLoyal Loyalty Engine API URL (`bloyal_custom_loyaltyengine_api_url`) and the `is_bloyal_custom_api_url` flag via the unprotected AJAX actions, then trigger the unauthenticated `/cart` REST route to cause `bloyal_customer_auto_login` to fetch customer data from an attacker-controlled endpoint and call `wp_set_auth_cookie()` with an attacker-supplied `Customer.ExternalId`, thereby authenticating as any WordPress user including the site Administrator.

NVD CVE-2026-15001Wordfence advisoryPlugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
bLoyal vulnerability status badge
<a href="https://laskyr.com/plugins/bloyal"><img src="https://laskyr.com/plugins/bloyal/badge.svg" alt="bLoyal vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit