Plugins · blog-posts-and-category-for-elementor · data as of 2026-11-04
Is Blog, Posts and Category Filter for Elementor safe? Known vulnerabilities and latest version
- Latest version
- 2.1.0
- Last updated
- 2025-04-26
- Active installs
- 1,000+
- Known issues on record
- 3
- Unpatched in latest
- 1
- Tested up to WP
- 6.8.12 · PHP 7.4+
Blog, Posts and Category Filter for Elementor lets you filter your Blog posts with Category. You can now display more posts to your users. — by Plugin Devs
What to do
- There is no fixed version yet. If you can live without Blog, Posts and Category Filter for Elementor for now, deactivate it and delete it until the developer ships a fix.
- If you must keep it, limit who can log in (remove unused accounts, especially low-level ones) and put a web application firewall in front of the site.
- Watch for an update: get an email when this page changes.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan, or have us clean it: Emergency Cleanup, $499.
With WP-CLI: wp plugin get blog-posts-and-category-for-elementor --field=version shows what you run; wp plugin update blog-posts-and-category-for-elementor updates it.
Check your version
Known vulnerabilities
3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
high 7.1 affects latest 2.1.0 CVE-2026-40806 · published 2026-10-06
Cross-site scripting (XSS) in Blog, Posts and Category Filter for Elementor (2.1.0 and older)
- Affected
- 2.1.0 and older
- Fixed in
- no fix listed yet
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Unauthenticated Cross Site Scripting (XSS) in Blog, Posts and Category Filter for Elementor <= 2.1.0 versions.
medium 6.5 CVE-2025-22648 · published 2025-03-27
Stored cross-site scripting (XSS) in Blog, Posts and Category Filter for Elementor (2.0.1 and older)
- Affected
- 2.0.1 and older
- Fixed in
- 2.1.0
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Plugin Devs Blog, Posts and Category Filter for Elementor blog-posts-and-category-for-elementor allows Stored XSS.This issue affects Blog, Posts and Category Filter for Elementor: from n/a through <= 2.0.1.
medium 5.4 CVE-2024-4667 · published 2024-07-09
Stored cross-site scripting (XSS) in Blog, Posts and Category Filter for Elementor (1.0.3 and older)
- Affected
- 1.0.3 and older
- Fixed in
- 2.0.0 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
The Blog, Posts and Category Filter for Elementor plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the Post and Category Filter widget in all versions up to, and including, 1.0.3 due to insufficient input sanitization and output escaping on user supplied 'post_types' attribute. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
NVD CVE-2024-4667Wordfence advisorywordpress.orgPlugin source
Recent activity
- 2025-04-26 — latest release on wordpress.org (2.1.0).
- 2026-10-06 — Cross-site scripting (XSS) disclosed (CVE-2026-40806), no fix listed yet.
- 2025-03-27 — Stored cross-site scripting (XSS) disclosed (CVE-2025-22648), fixed in 2.1.0.
- 2024-07-09 — Stored cross-site scripting (XSS) disclosed (CVE-2024-4667), fixed in 2.0.0.
Get an email when Blog, Posts and Category Filter for Elementor has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Blog, Posts and Category Filter for Elementor (blog-posts-and-category-for-elementor) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Cross-site scripting (XSS) (3)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/blog-posts-and-category-for-elementor (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/blog-posts-and-category-for-elementor"><img src="https://laskyr.com/plugins/blog-posts-and-category-for-elementor/badge.svg" alt="Blog, Posts and Category Filter for Elementor vulnerability status"></a>