Skip to content
Laskyr

Plugins · blog-floating-button · data as of 2026-11-04

Is Blog Floating Button safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.4.21)

As of 2026-11-04. 3 issues are on record for older versions; version 1.4.21 or newer fixes all of them that state a fix.

Latest version
1.4.21
Last updated
2026-07-31
Active installs
8,000+
Known issues on record
3
Unpatched in latest
0
Tested up to WP
7.0.8 · PHP 8.2+

Blog Floating Button (BFB) adds customizable floating buttons to your WordPress site and directs visitors to key landing pages. — by 1meril

What to do

  1. Update to the latest version (1.4.21). Anything older than 1.4.21 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get blog-floating-button --field=version shows what you run; wp plugin update blog-floating-button updates it.

Check your version

Known vulnerabilities

3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 7.1 CVE-2026-28170 · published 2026-08-13

Cross-site scripting (XSS) in Blog Floating Button (1.4.20 and older)

Affected
1.4.20 and older
Fixed in
1.4.21
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Unauthenticated Cross Site Scripting (XSS) in Blog Floating Button <= 1.4.20 versions.

NVD CVE-2026-28170Patchstack advisory

medium 6.1 CVE-2026-15383 · published 2026-08-03

Cross-site scripting (XSS) in Blog Floating Button (1.4.20 and older)

Affected
1.4.20 and older
Fixed in
1.4.21 *
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory

The Blog Floating Button WordPress plugin through 1.4.20 does not sanitize or escape the visitor User-Agent header, which it stores through an unauthenticated tracking REST endpoint and later renders unescaped in an administrator report page. This allows an unauthenticated attacker to store a malicious script that executes in the session of any administrator who views the access report, leading to site takeover.

NVD CVE-2026-15383WPScan advisory

high 8.8 CVE-2023-27445 · published 2023-11-13

Cross-site request forgery (CSRF) in Blog Floating Button (1.4.12 and older)

Affected
1.4.12 and older
Fixed in
1.4.13
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Cross-Site Request Forgery (CSRF) vulnerability in Meril Inc. Blog Floating Button plugin <= 1.4.12 versions.

NVD CVE-2023-27445Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Blog Floating Button vulnerability status badge
<a href="https://laskyr.com/plugins/blog-floating-button"><img src="https://laskyr.com/plugins/blog-floating-button/badge.svg" alt="Blog Floating Button vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit