Plugins · blog-filter · data as of 2026-11-04
Is Blog Filter safe? Known vulnerabilities and latest version
- Latest version
- 1.8.7
- Last updated
- 2026-09-01
- Active installs
- 7,000+
- Known issues on record
- 3
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 7.0+
Create a responsive Blog Filter Post Grid to showcase posts. Let visitors filter by Category or Tag easily using Ajax. Supports Elementor and Divi. — by A WP Life
What to do
- Update to the latest version (1.8.7). Anything older than 1.7.7 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get blog-filter --field=version shows what you run; wp plugin update blog-filter updates it.
Check your version
Known vulnerabilities
3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 6.5 CVE-2026-39517 · published 2026-04-08
Cross-site scripting (XSS) in Blog Filter (1.7.6 and older)
- Affected
- 1.7.6 and older
- Fixed in
- 1.7.7
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in A WP Life Blog Filter blog-filter allows DOM-Based XSS.This issue affects Blog Filter: from n/a through <= 1.7.6.
medium 6.5 CVE-2025-69033 · published 2025-12-30
Cross-site scripting (XSS) in Blog Filter (1.7.3 and older)
- Affected
- 1.7.3 and older
- Fixed in
- 1.7.4
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in A WP Life Blog Filter blog-filter allows DOM-Based XSS.This issue affects Blog Filter: from n/a through <= 1.7.3.
medium 5.4 CVE-2023-5291 · published 2023-10-04
Stored cross-site scripting (XSS) in Blog Filter (1.5.3 and older)
- Affected
- 1.5.3 and older
- Fixed in
- 1.5.4 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
The Blog Filter plugin for WordPress is vulnerable to Stored Cross-Site Scripting via 'AWL-BlogFilter' shortcode in versions up to, and including, 1.5.3 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers with contributor-level and above permissions to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
NVD CVE-2023-5291Wordfence advisoryCode change (fix)Plugin source
Recent activity
- 2026-09-01 — latest release on wordpress.org (1.8.7).
- 2026-04-08 — Cross-site scripting (XSS) disclosed (CVE-2026-39517), fixed in 1.7.7.
- 2025-12-30 — Cross-site scripting (XSS) disclosed (CVE-2025-69033), fixed in 1.7.4.
- 2023-10-04 — Stored cross-site scripting (XSS) disclosed (CVE-2023-5291), fixed in 1.5.4.
Get an email when Blog Filter has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Blog Filter (blog-filter) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by A WP Life (8 tracked)
Types found in this plugin: Cross-site scripting (XSS) (3)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/blog-filter (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/blog-filter"><img src="https://laskyr.com/plugins/blog-filter/badge.svg" alt="Blog Filter vulnerability status"></a>